Download it now!
Bug 133924 - FILESAVE DOCX Frame Wrap around property saved incorrectly
Summary: FILESAVE DOCX Frame Wrap around property saved incorrectly
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1 all versions
Hardware: All All
: medium normal
Assignee: Tibor Nagy (NISZ)
URL:
Whiteboard: target:7.1.0 target:7.0.0.1
Keywords: bibisected, bisected
Depends on:
Blocks: DOCX-Frames
  Show dependency treegraph
 
Reported: 2020-06-12 10:58 UTC by NISZ LibreOffice Team
Modified: 2020-09-02 13:02 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
The original file saved by Writer (10.17 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-06-12 10:58 UTC, NISZ LibreOffice Team
Details
Screenshot of the original and exported document side by side in Writer (127.63 KB, image/png)
2020-06-12 10:59 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-06-12 10:58:16 UTC
Created attachment 161911 [details]
The original file saved by Writer

When a frame object made in Word has the Wrap text property set as Yes, it is imported correctly as Page Wrap (since bug #107119 was fixed).
On saving however the Wrap text property becomes No (in Word) or 

Steps to reproduce:
    1. Open attachment #161009 [details] in Writer and save it as DOCX, then reopen

Actual results:
First frame is not wrapped around by text.

Expected results:
First frame should be wrapped around by text.

LibreOffice details:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 7f6d7a0eb624d67421cd5af6462ee2a662fdff3a
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 1 NISZ LibreOffice Team 2020-06-12 10:59:48 UTC
Created attachment 161912 [details]
Screenshot of the original and exported document side by side in Writer
Comment 2 Commit Notification 2020-06-19 12:18:04 UTC
Tibor Nagy committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9bbc60c0d5e60eacecd624f343aecc94e4219c84

tdf#133924 DOCX export: fix text wraps around frame

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Xisco Faulí 2020-06-19 13:06:01 UTC
it seems it started to happen after https://cgit.freedesktop.org/libreoffice/core/commit/?id=be02ce71f2ee694fa2609a7a630853c24acfbfff
Comment 4 Xisco Faulí 2020-06-24 10:19:11 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: cb72269f93a20dd175dae3dcf30740c9931e7684
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Tibor, thanks for fixing this issue!!
Comment 5 Commit Notification 2020-06-24 10:21:14 UTC
Tibor Nagy committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/d4dbf1cc87ae21567acc96a409974f1d159d550f

tdf#133924 DOCX export: fix text wraps around frame

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.