Download it now!
Bug 133982 - CRASH: copying content in nested table
Summary: CRASH: copying content in nested table
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:7.1.0 target:6.4.6 target:7.0....
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Crash
  Show dependency treegraph
 
Reported: 2020-06-14 11:01 UTC by Xisco Faulí
Modified: 2020-07-01 10:11 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-06-14 11:01:36 UTC
Steps to reproduce:
1. Open attachment 104793 [details] from bug 82452
2. Use select all 3 times
3. Copy

-> Crash

Reproduced in

Version: 7.1.0.0.alpha0+
Build ID: ff508f6d8a3e58d29e9e7622006a7103fb0a2849
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-06-14 11:03:17 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=ef8427d12a63127a2eb867637699343d630545dd

author	Michael Stahl <Michael.Stahl@cib.de>	2020-01-21 13:15:50 +0100
committer	Michael Stahl <michael.stahl@cib.de>	2020-01-30 14:18:46 +0100
commit	ef8427d12a63127a2eb867637699343d630545dd (patch)
tree	b3312295b36246c8bad99e417639445cfe23670e
parent	3a248dfe57318af57fc5df89652cb64dfa923e46 (diff)
tdf#45589 sw: invalidate on bookmark insertion/deletion

Bisected with: bibisect-linux64-7.0

Adding Cc: to Michael Stahl
Comment 2 Xisco Faulí 2020-06-14 11:09:53 UTC
Also reproduced following the same steps with attachment 94522 [details] from bug 75331
Comment 3 Commit Notification 2020-06-18 08:18:05 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/310271df2e4dc67d223dbec4b23e39ea4a67c042

tdf#133982 sw: fix Copy of document that starts with nested table

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Michael Stahl (CIB) 2020-06-18 08:21:11 UTC
this was always copying bookmarks wrongly, at least since the extended-select-all feature that copies tables at the start, but maybe it didn't crash before the commit in comment#2

fixed on master
Comment 5 Commit Notification 2020-06-18 12:00:34 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/7866336f1ce3d5b686847e98a218e6b4d4ca9db5

tdf#133982 sw: fix Copy of document that starts with nested table

It will be available in 6.4.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2020-06-18 12:43:24 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/ad4f96d6a51744a48988bf80c0d059d86a4e8897

tdf#133982 sw: fix Copy of document that starts with nested table

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2020-06-18 14:48:41 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9197a52c1bd79bbdc0756724c74fd2a679b9f626

tdf#133982: sw: Add unittest

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2020-06-24 14:13:52 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-4-5":

https://git.libreoffice.org/core/commit/ff6911b3afdacc82ed6a42f3a7a1b852931840d0

tdf#133982 sw: fix Copy of document that starts with nested table

It will be available in 6.4.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 BogdanB 2020-06-24 17:17:59 UTC
Verified in 7.0. It's ok now.
Version: 7.0.0.0.beta2+
Build ID: 77e4943cc6cf206a45901e5c87fabf0f783c8262
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-7-0, Time: 2020-06-24_02:22:53
Calc: threaded