Bug 134006 - Crash/ Freeze after undo changes in an old swx
Summary: Crash/ Freeze after undo changes in an old swx
Status: RESOLVED DUPLICATE of bug 133967
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: All All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, haveBacktrace, regression
Depends on:
Blocks: Undo-Redo
  Show dependency treegraph
 
Reported: 2020-06-15 18:07 UTC by Telesto
Modified: 2020-08-05 10:48 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
bt with debug symbols (gen) (6.81 KB, text/plain)
2020-06-16 10:36 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-06-15 18:07:23 UTC
Description:
Crash/ Freeze after undo changes in an old swx

Steps to Reproduce:
Steps to Reproduce:
1. Open https://bz.apache.org/ooo/attachment.cgi?id=15387
https://bz.apache.org/ooo/show_bug.cgi?id=24533
2. CTRL+A
3. CTRL+X
4. CTRL+A
5. CTRL+X
6. CTRL+Z
7. CTRL+Z -> 7.1 Freeze 6.4 Crash


Actual Results:
Freeze or crash

Expected Results:
Should ideally work


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: a35c18aeff3b1d8f270db7e094850fb8ba1ab84a
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: GL; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-06-15 18:11:03 UTC
Fine with 
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL
Comment 2 Julien Nabet 2020-06-16 10:36:51 UTC
Created attachment 162045 [details]
bt with debug symbols (gen)

On pc Debian x86-64 with master sources updated today, I got an assertion after just:
- Ctrl A
- Ctrl X
Comment 3 Xisco Faulí 2020-06-16 10:41:18 UTC
LibreOffice crashes for me on step 3 after cutting the content

Version: 7.1.0.0.alpha0+
Build ID: 11d21b3c1f7754b5d13ae9ea88da562ec74366ff
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

Version: 6.3.0.0.alpha1+
Build ID: c98b1f1cd43b3e109bcaf6324ef2d1f449b34099
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Telesto, does it happen for you if you wait a bit after step 3 ?
Comment 4 Julien Nabet 2020-06-18 13:16:10 UTC
Buovjaga: I agree with the fact undo/layout is not stable but "critical" for an old format like "swx" + process to reproduce this more "treasure map game" than straightforward ?
Comment 5 Buovjaga 2020-06-18 13:43:54 UTC
(In reply to Julien Nabet from comment #4)
> Buovjaga: I agree with the fact undo/layout is not stable but "critical" for
> an old format like "swx" + process to reproduce this more "treasure map
> game" than straightforward ?

Critical tells us about the severity of the effect. The aspect you are thinking of is priority, which I did not touch.
Comment 6 Xisco Faulí 2020-08-05 10:48:51 UTC
This issue has been fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=14e87a4b15d31a34e6053f6194688f3aa23af991.
Closing as a dupe of bug 133967

*** This bug has been marked as a duplicate of bug 133967 ***