Download it now!
Bug 134019 - Calc FILEOPEN Crash in: sclo.dll
Summary: Calc FILEOPEN Crash in: sclo.dll
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.6.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.0.0 target:6.4.5
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-15 21:45 UTC by christos
Modified: 2020-06-24 10:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: ["sclo.dll"]


Attachments
Simulation: calculations involving random numbers, many previously used lines deleted (69.43 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-06-15 21:45 UTC, christos
Details

Note You need to log in before you can comment on or make changes to this bug.
Description christos 2020-06-15 21:45:53 UTC
Created attachment 162025 [details]
Simulation: calculations involving random numbers, many previously used lines deleted

This bug was filed from the crash reporting server and is br-07d20d42-6008-4a65-b00e-044a5ad70c87.
=========================================
LibreOffice crashes when opening the attached ods file created with the same version of LibreOffice. I created it and worked on it over a number of days, then reset the properties and saved again. I made some more changes, then reloaded the saved file. LibreOffice crashed and has been crashing ever since (although just one of many later attempts to open the file was successful).

br-a530468d-e662-41c6-aefd-1946af331336 is an earlier crash, which I thought I could not reproduce since I was able to continue working on the file after that.

I have tried safe mode, resetting both the settings and user profile to no avail. I have also tried deleting the .~lock file.

Incidentally, the dialog that appears when I try to start LibreOffice by opening this file is misleading. "Due to an error, LibreOffice crashed. All the files you were working on will now be saved. The next time LibreOffice is launched, your files will be recovered automatically." In fact, there have been no new changes to save. Underneath the above message, the list of files to be recovered is empty.
Comment 1 Julien Nabet 2020-06-16 08:55:01 UTC
On Win10 with master sources updated today, I don't reproduce this.

Could you give a try to 6.4.4 + take a look at https://wiki.documentfoundation.org/QA/FirstSteps ?
Comment 2 christos 2020-06-16 19:55:31 UTC
I installed fresh (6.4.4.2) in parallel. No luck though. It crashed in both normal and safe mode when opening this file.

Same results on a PC with GNU/Linux, LibreOffice version 6.4.3.2, build ID 1:6.4.3-0ubuntu0.20.04.1.
Comment 3 Xisco Faulí 2020-06-17 15:57:36 UTC
it doesn't crash for me in

Version: 7.1.0.0.alpha0+
Build ID: 27381dc1b76e4aee5459b3d85e6fc5919d2b8f98
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 4 Xisco Faulí 2020-06-17 16:10:07 UTC
This got fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=8e3a29110c8ad739bedeea90932663608d8d3935

Closing a RESOLVED FIXED and backporting the patch to libreoffice-6-4
Comment 5 Commit Notification 2020-06-18 06:55:30 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/74def786fe5c20c5415060209e56ee30cde8e266

tdf#134019: ofz#20904 check bounds

It will be available in 6.4.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2020-06-24 10:39:29 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4-5":

https://git.libreoffice.org/core/commit/c54b0146594f0d1fe8070c4228e5c02eb27dfed5

tdf#134019: ofz#20904 check bounds

It will be available in 6.4.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.