Download it now!
Bug 134023 - Select the table by dragging over the columns become harder
Summary: Select the table by dragging over the columns become harder
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Justin L
URL:
Whiteboard: target:7.1.0 target:7.0.0.1 target:6.4.5
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-06-16 08:27 UTC by Telesto
Modified: 2020-06-24 17:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screencast (1.69 MB, video/mp4)
2020-06-16 08:27 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-06-16 08:27:06 UTC
Description:
Select the table by dragging over the columns become harder

Steps to Reproduce:
1. Open attachment 162020 [details]
2. Hoover over the top of the column until the arrow appears click and hold left click + drag -> select the columns

Actual Results:
Columns not selected

Expected Results:
Should be so


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: a35c18aeff3b1d8f270db7e094850fb8ba1ab84a
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-06-16 08:27:56 UTC
Created attachment 162031 [details]
Screencast
Comment 2 Telesto 2020-06-16 08:28:12 UTC
Not in 
6.1
Comment 3 Attila Baraksó (NISZ) 2020-06-16 15:32:51 UTC
Reproduced in:

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 33a720ab802491f15b247e09755cd36205b6f435
CPU szálak: 4; OS: Windows 10.0 Build 17134; Felületmegjelenítés: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: CL
Comment 4 Attila Baraksó (NISZ) 2020-06-16 16:58:02 UTC
Bibisected using bibisect-win64-6.4 to:
URL: https://cgit.freedesktop.org/libreoffice/core/commit/?id=fee310ddda7ea7452107b9528776cbcc7c7db9f0
author: Justin Luth <justin.luth@collabora.com>
committer: Xisco Faulí <xiscofauli@libreoffice.org>
summary: tdf#84929 sw UI: stay at footer when showing control

Adding CC: Justin Luth
Comment 5 Justin L 2020-06-16 18:40:55 UTC
Looks like I will need to figure out how to implement "One additional limitation could be added to only apply this if it is dealing with the footer, since in the case of a header there would be no screen-jump."
Comment 6 Justin L 2020-06-17 06:09:43 UTC
proposed patch at https://gerrit.libreoffice.org/c/core/+/96487 tdf#134023
Comment 7 Commit Notification 2020-06-17 07:00:49 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c3cf3e908add6b6617eb0ee12385fbd8a70a9887

tdf#134023 sw ui: stay at footer ONLY when showing control

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2020-06-17 11:50:17 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/df4585686eb56d95a871dd528ad06fd980a58591

tdf#134023 sw ui: stay at footer ONLY when showing control

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2020-06-19 08:27:29 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/c441cc1529d21cb9dd9aac92f28601ff8b111745

tdf#134023 sw ui: stay at footer ONLY when showing control

It will be available in 6.4.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Xisco Faulí 2020-06-24 14:36:36 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: cb72269f93a20dd175dae3dcf30740c9931e7684
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Justin Luth, Thanks for fixing this issue. Can it be closed as RESOLVED FIXED ?
Comment 11 Commit Notification 2020-06-24 14:39:29 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-6-4-5":

https://git.libreoffice.org/core/commit/358e13bbb6f9e632df7d75af5535707f97832d25

tdf#134023 sw ui: stay at footer ONLY when showing control

It will be available in 6.4.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Justin L 2020-06-24 17:56:11 UTC
(In reply to Xisco Faulí from comment #10)
> Can it be closed as RESOLVED FIXED ?
I was waiting for all the backports to 6.4.5 to finish before marking it as finished.