Download it now!
Bug 134052 - FILEOPEN PPTX: shadow appears solid instead of blurry in presentation mode
Summary: FILEOPEN PPTX: shadow appears solid instead of blurry in presentation mode
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: ahmad_g
URL:
Whiteboard: target:7.1.0
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-16 21:54 UTC by Gerald Pfeifer
Modified: 2020-08-31 11:28 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample PPTX document (15.38 MB, application/vnd.ms-powerpoint)
2020-06-16 21:54 UTC, Gerald Pfeifer
Details
How it looks in LibreOffice (hard shadows) (41.61 KB, image/png)
2020-06-16 21:55 UTC, Gerald Pfeifer
Details
This is how it looks in Office 365 (soft shadows) (54.21 KB, image/png)
2020-06-16 21:56 UTC, Gerald Pfeifer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer 2020-06-16 21:54:41 UTC
Created attachment 162078 [details]
Sample PPTX document

In the sample document, shadows appear blurry in Office 365 and solid in
LibreOffice 7.1alpha1 (and 6.4.4.2).

Note 1: This is not about the blurry edges feature, which would affect the
primary shape (= rectangles here), but blurrying the shadows.

Note 2: The sample document has two slides exhibiting the same issue.
Comment 1 Gerald Pfeifer 2020-06-16 21:55:56 UTC
Created attachment 162079 [details]
How it looks in LibreOffice (hard shadows)
Comment 2 Gerald Pfeifer 2020-06-16 21:56:26 UTC
Created attachment 162080 [details]
This is how it looks in Office 365 (soft shadows)
Comment 3 Xisco Faulí 2020-06-17 08:43:41 UTC
I can't reproduce it in

Version: 7.1.0.0.alpha0+
Build ID: 11d21b3c1f7754b5d13ae9ea88da562ec74366ff
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

Could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ?
You can install it alongside the standard version.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the master build
Comment 4 Gerald Pfeifer 2020-06-17 09:08:06 UTC
(In reply to Xisco Faulí from comment #3)
> I can't reproduce it in
> 
> Version: 7.1.0.0.alpha0+
> Build ID: 11d21b3c1f7754b5d13ae9ea88da562ec74366ff
> CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
> Locale: en-US (en_US.UTF-8); UI: en-US
> Calc: threaded
> 
> Could you please try to reproduce it with a master build from
> http://dev-builds.libreoffice.org/daily/master/ ?
> You can install it alongside the standard version.
> I have set the bug's status to 'NEEDINFO'. Please change it back to
> 'UNCONFIRMED' if the bug is still present in the master build

The screenshot I shared for LibreOffice was taken with

  Version: 7.1.0.0.alpha0+
  Build ID: cd47dba9aa4b91bb0edf0744561d29e2eef61cc9
  CPU threads: 4; OS: Linux 5.6; UI render: default; VCL: gtk3
  Locale: en-US (en_US.UTF-8); UI: en-US
  TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-06-11_19:46:20
  Calc: threaded

and I re-confirmed it really looks that way with that. I found there is a
build dated 2020-06-15 now (four days newer) and will give that a try.
Comment 5 Xisco Faulí 2020-06-17 09:19:16 UTC
Indeed, it was wrong 4 days ago and it was fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=b435c4fe82e77a82fde6464d6722281e5fc4f394
Comment 6 Xisco Faulí 2020-06-17 10:31:31 UTC
@A_GAN, any chance you could created a unittest for this issue you fixed ?
Comment 7 ahmad_g 2020-06-17 13:47:37 UTC
The pptx file I made in MS PowerPoint with a blurry shadow and used it for testing the import of the blur radius.

I've already made a unit test for importing the radius here: https://opengrok.libreoffice.org/xref/core/sd/qa/unit/import-tests.cxx?r=88a5f776#3124

to check that I've got it correct but not available to be seen yet.

Then Later I've created process function which is responsible to create the blurring effect on the shadow of the shape and view it.

Here's the function that resolved the bug:
https://opengrok.libreoffice.org/xref/core/drawinglayer/source/processor2d/vclpixelprocessor2d.cxx?r=b435c4fe#1077

Now, it's available to see the blurring shadow as part of my GSoC project
Comment 8 Gerald Pfeifer 2020-06-17 15:34:57 UTC
(In reply to Xisco Faulí from comment #5)
> Indeed, it was wrong 4 days ago and it was fixed by
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=b435c4fe82e77a82fde6464d6722281e5fc4f394

Yep, confirmed now on the same system, after another update. 

Version: 7.1.0.0.alpha0+
Build ID: a3c8ea5e644ca2fc04de9f01ba9f8ace47f520f0
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-06-17_02:21:20
Comment 9 Gerald Pfeifer 2020-06-17 15:44:33 UTC
Oh, wait! This has been addressed in edit mode only.

In presentation mode it still looks like the attached screenshot labeled
"How it looks in LibreOffice (hard shadows)".  Reopening this bug report.
Comment 10 Xisco Faulí 2020-06-17 15:46:33 UTC
(In reply to ahmad_g from comment #7)
> The pptx file I made in MS PowerPoint with a blurry shadow and used it for
> testing the import of the blur radius.
> 
> I've already made a unit test for importing the radius here:
> https://opengrok.libreoffice.org/xref/core/sd/qa/unit/import-tests.
> cxx?r=88a5f776#3124
> 
> to check that I've got it correct but not available to be seen yet.
> 
> Then Later I've created process function which is responsible to create the
> blurring effect on the shadow of the shape and view it.
> 
> Here's the function that resolved the bug:
> https://opengrok.libreoffice.org/xref/core/drawinglayer/source/processor2d/
> vclpixelprocessor2d.cxx?r=b435c4fe#1077
> 
> Now, it's available to see the blurring shadow as part of my GSoC project

Hello ahmad, thanks for the great work here!
I believe https://cgit.freedesktop.org/libreoffice/core/commit/?id=b435c4fe82e77a82fde6464d6722281e5fc4f394 was submitted right after your wrote those unittests, thus there's no unittest covering this issue, isn't it ?
Comment 11 ahmad_g 2020-06-18 18:48:21 UTC
(In reply to Xisco Faulí from comment #10)
> (In reply to ahmad_g from comment #7)
> > The pptx file I made in MS PowerPoint with a blurry shadow and used it for
> > testing the import of the blur radius.
> > 
> > I've already made a unit test for importing the radius here:
> > https://opengrok.libreoffice.org/xref/core/sd/qa/unit/import-tests.
> > cxx?r=88a5f776#3124
> > 
> > to check that I've got it correct but not available to be seen yet.
> > 
> > Then Later I've created process function which is responsible to create the
> > blurring effect on the shadow of the shape and view it.
> > 
> > Here's the function that resolved the bug:
> > https://opengrok.libreoffice.org/xref/core/drawinglayer/source/processor2d/
> > vclpixelprocessor2d.cxx?r=b435c4fe#1077
> > 
> > Now, it's available to see the blurring shadow as part of my GSoC project
> 
> Hello ahmad, thanks for the great work here!

Thank you!

> I believe
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=b435c4fe82e77a82fde6464d6722281e5fc4f394 was submitted right after your
> wrote those unittests, thus there's no unittest covering this issue, isn't
> it ?

Yes, the process function was submitted after the import unit test. I am still working on the blurring of the shadow. 

What kind of unit test that covers this issue?
Comment 12 Gerald Pfeifer 2020-07-29 14:39:00 UTC
(In reply to Gerald Pfeifer from comment #9)
> Oh, wait! This has been addressed in edit mode only.
> 
> In presentation mode it still looks like the attached screenshot labeled
> "How it looks in LibreOffice (hard shadows)".  Reopening this bug report.

Ahmad, do you have an outlook on when/whether you will be able to address
this?  That would be awesome, thank you!
Comment 13 ahmad_g 2020-07-29 20:06:07 UTC
(In reply to Gerald Pfeifer from comment #12)
> (In reply to Gerald Pfeifer from comment #9)
> > Oh, wait! This has been addressed in edit mode only.
> > 
> > In presentation mode it still looks like the attached screenshot labeled
> > "How it looks in LibreOffice (hard shadows)".  Reopening this bug report.
> 
> Ahmad, do you have an outlook on when/whether you will be able to address
> this?  That would be awesome, thank you!


It could be supported but the transparency of the blurred shadow will be having some problems in presentation mode. I am trying to figure it out but still stuck in it.
Comment 14 Gerald Pfeifer 2020-08-08 19:46:44 UTC
Hi Mike, you reviewed the original patch that added this in edit mode.

Do you maybe have an idea/hint how to also make this work in presentation
mode?  Thanks!
Comment 15 Commit Notification 2020-08-17 19:03:41 UTC
A_GAN committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b6e508fc47ecb3650fd82c5e174e6d6a084e9ec6

tdf#134052:shadow appears solid instead of blurry in presentation mode

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Gerald Pfeifer 2020-08-23 10:00:05 UTC
I am happy to confirm this is fixed for me with current 7.1 builds
- thank you!

Are you going to also push this back into the 7.0 tree?
Comment 17 Xisco Faulí 2020-08-31 11:26:43 UTC
(In reply to Gerald Pfeifer from comment #16)
> I am happy to confirm this is fixed for me with current 7.1 builds
> - thank you!
> 
> Are you going to also push this back into the 7.0 tree?

This is part of the GSOC project 'Blurry Shadows', see https://ahmadganzouri.blogspot.com/2020/08/gsoc-2020-final-report.html#more
You will have to wait for LibreOffice 7.1
Comment 18 Xisco Faulí 2020-08-31 11:28:12 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: e2f4e65a7b8024c00b049eebf0d87637efda7f24
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Ahmad, thanks for fixing this issue!