Bug 134078 - Printing not working on Version: 6.4.3.2 in Lubuntu with GTK3 and physical Brother printer (print to PDF works)
Summary: Printing not working on Version: 6.4.3.2 in Lubuntu with GTK3 and physical Br...
Status: RESOLVED DUPLICATE of bug 125234
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.4.3.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-17 19:00 UTC by mmoa33
Modified: 2020-09-18 14:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mmoa33 2020-06-17 19:00:19 UTC
Description:
Any document or sheet I try to send to the printer, is printed as gibberish characters. Only pictures are correctly printed. but no text.

Steps to Reproduce:
1. Open a non empty text or spreadsheet document
2. try to print
3. Look at paper

Actual Results:
only garbage characters appear, and pictures -if any- do appear printed

Expected Results:
Everything content is visible on the screen should appear


Reproducible: Always


User Profile Reset: No



Additional Info:
I am using a Brother HL-1200. If I print PDF files it does well.
Comment 1 Timur 2020-07-02 07:53:58 UTC
Did it work before with previous LO and same printer? 
Did you change Linux or driver version? 
Does it work from other apps? 
See also indicates problem with Brother printer. 
Can you test LO daily master? 
Please copy LO info from Help About. 
To see if UI specific, please test running LO with:
SAL_USE_VCLPLUGIN=gen soffice
Comment 2 mmoa33 2020-07-02 13:24:36 UTC
As per the questions below:

1.  I upgraded from Lubuntu 18.04 to 20.04. IN 18.04 it printed; however I cannot remember which LO version I had then.

2. Printing does work with PDF files opened in Document Viewer.

3. I cannot test LO daily master

4. About information:


Version: 6.4.3.2
Build ID: 1:6.4.3-0ubuntu0.20.04.1
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

5. Using SAL_USE_VCLPLUGIN=gen soffice solves the issue! I tested with some text documents and spreadsheets.
Comment 3 Timur 2020-07-02 16:31:57 UTC
Fixed bug is when there was commit. 
Using old generic environment is not a solution, it's a workaround. 
I'm not sure what would be the right status for this bug. 
We had Lubuntu bug 132569 and bug 132764 but they are for PDF export with Qt5 (you are using gtk3, you may test qt5). 
We also have other Brother bugs. 
Let's keep it open for a while. 
I change the title, I understand print to PDF Cups works (you didn't mention Export to PDF). 
In the meantime please search Lubuntu bugs for this problem.
Comment 4 mmoa33 2020-07-02 19:39:24 UTC
You wrote "I understand print to PDF Cups works". 

Maybe I was not clear above, but printing PDF files (generated outside LO) 
works. If I try to export to PDF, then I will see the same gibberish I see when I try to print right to the printer.
Comment 5 Zsolt 2020-09-18 08:03:42 UTC
Hi,

I have the same problem.

The Linux is Lubuntu 20.04 LTS. The LibreOffice is 6.4.5.2, but i have tried also a 7.0.1.2 portable. The LO 6.4.5.2 is the official version from ubuntu. It is installed from repo. The printer is an Epson L355.
If i try to print or export to PDF, I get only the graphics. I get no text. It prits nothing from text. (no rubbish)

I whould say, you lost all your fonts.

The GIMP prints on the same Linux. Firefox prints on the same linux. If i export my spreadsheet to html, it ptints.

If I print the same file on a Ubuntu 18 it works.
If I copy the file to a Windows, on windows export it with the same LO (but windows build) to PDF and copy the PDF back to the Lubuntu 20.04 -> it prints.
Comment 6 Timur 2020-09-18 10:27:11 UTC Comment hidden (me-too)
Comment 7 Timur 2020-09-18 10:28:16 UTC
Please try daily master from https://dev-builds.libreoffice.org/daily/master/current.html, it is separate to your working LO.
There was a recent fix in bug 125234, to see if this is a duplicate.
Comment 8 Zsolt 2020-09-18 13:06:03 UTC
YES! The 7.1.0.0 prints.

Thank You!

I read the other record. It seems me to be the same. It must be the same, it solvs my problem.

Thank you again

bye
Comment 9 Timur 2020-09-18 14:13:56 UTC

*** This bug has been marked as a duplicate of bug 125234 ***