Bug 134099 - BigPtrArray::Index2Block undo crash
Summary: BigPtrArray::Index2Block undo crash
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium critical
Assignee: Miklos Vajna
URL:
Whiteboard: target:7.1.0 target:7.0.0.1 target:6.4.6
Keywords: bibisected, bisected, haveBacktrace, regression
: 127329 (view as bug list)
Depends on:
Blocks: Undo-Redo
  Show dependency treegraph
 
Reported: 2020-06-18 10:12 UTC by Telesto
Modified: 2020-07-01 10:25 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
GDB trace of crash (23.08 KB, text/plain)
2020-06-18 11:47 UTC, Buovjaga
Details
minimal reproducer (40.29 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-06-18 11:52 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-06-18 10:12:24 UTC
Description:
BigPtrArray::Index2Block undo crash

Steps to Reproduce:
Another way to get the same crash signature < crashreport.libreoffice.org/stats/crash_details/870d593a-d4a8-444e-b5ab-dec2b7a18948 >

1. Open attachment 142123 [details] from bug 117638
2. Select all
3. Copy
4. Paste 5 times
5. Undo 6 times

-> Crash

Actual Results:
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
Version: 7.1.0.0.alpha0+ (x64)
Build ID: a35c18aeff3b1d8f270db7e094850fb8ba1ab84a
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

and in
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL

not in 
3.5.7.2
Comment 1 Buovjaga 2020-06-18 11:47:25 UTC
Created attachment 162151 [details]
GDB trace of crash

Arch Linux 64-bit
Version: 7.1.0.0.alpha0+
Build ID: ad0351b84926075297fb74abbe9b31a0455782af
CPU threads: 8; OS: Linux 5.7; UI render: default; VCL: kf5
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 17 June 2020
Comment 2 Buovjaga 2020-06-18 11:49:20 UTC
Bibisected with Linux 44max to https://git.libreoffice.org/core/+/c7307c77254557646f33017af915f6808a861e29%5E!/
fdo#82191 sw::DocumentLayoutManager: copy textbox content of draw formats

Adding Cc: to Miklos Vajna
Comment 3 Xisco Faulí 2020-06-18 11:52:00 UTC
Created attachment 162152 [details]
minimal reproducer
Comment 4 Miklos Vajna 2020-06-19 15:33:02 UTC
Xisco: why did you marked your minimal reproducer obsolete? I'm trying to figure out if it should spend time on creating one or use the one you attached. :-)
Comment 5 Xisco Faulí 2020-06-19 15:48:30 UTC
(In reply to Miklos Vajna from comment #4)
> Xisco: why did you marked your minimal reproducer obsolete? I'm trying to
> figure out if it should spend time on creating one or use the one you
> attached. :-)

it was for another ticket. I should have mentioned it. Sorry for that
Comment 6 Miklos Vajna 2020-06-30 12:06:55 UTC
Fixed with core.git 682e0488df819c191c13a03758fad0690706e508, just it seems the bugzilla notification is down. Also in libreoffice-7-0.
Comment 7 Commit Notification 2020-06-30 12:20:39 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/682e0488df819c191c13a03758fad0690706e508

tdf#134099 sw: fix textbox anchors on copy-paste and undo

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2020-06-30 12:41:56 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/15b2b8ab801c6faf797648d94de3c17228daf4ab

tdf#134099 sw: fix textbox anchors on copy-paste and undo

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2020-07-01 09:12:12 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/568e2e946b6cb21bd36baff4e3592629431765a0

tdf#134099 sw: fix textbox anchors on copy-paste and undo

It will be available in 6.4.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Xisco Faulí 2020-07-01 09:37:58 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: 7df1884118a0d995ec57679ef83e586c95063858
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Miklos, thanks for fixing this issue!!
Comment 11 Xisco Faulí 2020-07-01 09:39:46 UTC
*** Bug 127329 has been marked as a duplicate of this bug. ***