Bug 134107 - CRASH: undoing paste
Summary: CRASH: undoing paste
Status: RESOLVED DUPLICATE of bug 134101
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Crash-BigPtrArray
  Show dependency treegraph
 
Reported: 2020-06-18 12:34 UTC by Xisco Faulí
Modified: 2021-01-15 09:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: ["BigPtrArray::Index2Block(unsigned%20__int64)"]
Regression By:


Attachments
sample file (40.29 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-06-18 12:34 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-06-18 12:34:08 UTC
Created attachment 162154 [details]
sample file

Steps to reproduce:
1. Open attached document
2. CTRL+A
3. CTRL+C
4. CTRL+N
5. CTRL+V
6. CTRL+Z

-> Crash

Reproduced in

Version: 7.1.0.0.alpha0+
Build ID: 27381dc1b76e4aee5459b3d85e6fc5919d2b8f98
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-06-18 12:35:51 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=08f13ab85b5c65b5dc8adfa15918fb3e426fcc3c

author	Michael Stahl <Michael.Stahl@cib.de>	2019-12-16 12:58:46 +0100
committer	Michael Stahl <michael.stahl@cib.de>	2019-12-17 10:16:36 +0100
commit 08f13ab85b5c65b5dc8adfa15918fb3e426fcc3c (patch)
tree 0aa3c140eb2c76360aa2b91edc3bf6fe6aacb4f3
parent e9e57a3dbd8b780e0ae3c9015d757719b893f190 (diff)
tdf#112202 writerfilter,sw: fix loss of headers

Bisected with: bibisect-linux64-7.0

Adding Cc: to Michael Stahl
Comment 2 Telesto 2021-01-15 09:21:56 UTC
I'm not encountering a crash
Version: 7.2.0.0.alpha0+ (x64)
Build ID: f2171af6ce3516598d9f8bac8294025a21a5b1a2
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

Marking this resolved WFM.. 

@Xisco
Would you mind to double check?
Comment 3 Xisco Faulí 2021-01-15 09:45:42 UTC
issue fixed by 

author	Michael Stahl <Michael.Stahl@cib.de>	2020-12-10 11:22:13 +0100
committer	Michael Stahl <michael.stahl@cib.de>	2020-12-10 13:34:32 +0100
commit b4365b985178e1866c74afd757a104aad1d405a9 (patch)
tree 7aac322e0e1ef31e80127f46fdd414a872430251
parent 5dbb0403b6f814129983963f5fea02208995270a (diff)
tdf#134626 sw: fix UBSan warning about deleted SwTextFormatColl

@Michael Stahl, thanks for fixing this issue!!
Comment 4 Xisco Faulí 2021-01-15 09:49:58 UTC
Closing this one as a dupe of bug 134101

*** This bug has been marked as a duplicate of bug 134101 ***