Download it now!
Bug 134162 - UI: The Navigator's Navigation tool no longer allows you to select with the mouse the type of item you want to navigate through.
Summary: UI: The Navigator's Navigation tool no longer allows you to select with the m...
Status: RESOLVED DUPLICATE of bug 130004
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-20 08:47 UTC by pierre-yves samyn
Modified: 2020-06-20 14:21 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Reminder-1.png (82.90 KB, image/png)
2020-06-20 08:48 UTC, pierre-yves samyn
Details
Reminder-2.png (37.79 KB, image/png)
2020-06-20 08:48 UTC, pierre-yves samyn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pierre-yves samyn 2020-06-20 08:47:33 UTC
Description:
Normally it is possible to click the icon for the type of objects you want to browse through. Then click one of the "Previous Object" or "Next Object" arrow buttons.

Steps to Reproduce:
1. Open or create a new Writer doc
2. In the sidebar display the Navigator
3. Click on Navigation to display the toolbar (see Reminder-1.png attached)
4. Try to select e.g. "Reminder" or any type (see Reminder-2.png attached)

Actual Results:
The selected type is not selected. The selection remains the default tool (page navigation).

Expected Results:
The selected type is selected


Reproducible: Always


User Profile Reset: No



Additional Info:
1. Selection using the keyboard is still possible with the left and right arrows.
2. Another workaround: select the navigation mode in the Find toolbar.

Environment: 

Version: 6.4.4.2 (x64)
Build ID: 3d775be2011f3886db32dfd395a6a6d1ca2630ff
CPU threads: 2; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: default; VCL: win; 
Locale: fr-FR (fr_FR); UI-Language: en-US
Calc: threaded
Comment 1 pierre-yves samyn 2020-06-20 08:48:04 UTC
Created attachment 162223 [details]
Reminder-1.png
Comment 2 pierre-yves samyn 2020-06-20 08:48:27 UTC
Created attachment 162224 [details]
Reminder-2.png
Comment 3 V Stuart Foote 2020-06-20 14:21:05 UTC
The Navigation mode dialog has been removed for 7.0.0 and the Find bar control implemented as droplist on the Navigator deck, but this regression through 6.4.4 remains.

That is the inability to single-click select the mode from the Navigation dialog. 

Two work arounds 1) use the Navigation mode selection from the Find bar (integrated to Navigator deck for 7.0.0) or 2) Open the Navigation dialog -- use L/R keyboard cursor to advance to desired mode -- select with mouse click.

Anyhow this is a duplicate of bug 130004

*** This bug has been marked as a duplicate of bug 130004 ***