Bug 134180 - persian pdf files created by libreoffice, cant be read with nvda screen reader using libreoffice!
Summary: persian pdf files created by libreoffice, cant be read with nvda screen reade...
Status: RESOLVED DUPLICATE of bug 104597
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-21 09:09 UTC by zahra
Modified: 2020-06-24 12:46 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
the docx format of persian pdf file which i attached in my description (131.72 KB, application/zip)
2020-06-24 08:53 UTC, zahra
Details
one english pdf file which i downloaded today (377.02 KB, application/pdf)
2020-06-24 08:55 UTC, zahra
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zahra 2020-06-21 09:09:51 UTC
Description:
hello.
since i use windows xp, the last version of libreoffice which i can test is 5.4.7, so, not sure about newer versions.
i have a docx file.
i exported in to pdf, and tried to open it in libreoffice!
libreoffice draw, i think can display pdf files, but converts them to the shapes!
i use nvda screen reader.
when i tried this file with libreoffice, arrow keys dont work for me.
the only key which works for me is tab.
nvda says for example: shape 1 from 56.
i should press enter on it.
most times nvda says blank.
other times, read document in reverse order!
and i should read them letter by letter which is really annoying and waisting time!
for example:
instead of
ترجمه:
nvda says:
همجرت!
its true for all words and sentences of the file.
attached file is hear.

Actual Results:
i cant read pdf files, nvda reads them in the reverse order, even maybe libreoffice converts them to the picture instead of written pdf document.

Expected Results:
libreoffice converts the file in the text written file, (not image file which needs ocr programs), and shows it perfectly. nvda can reads correctly as it can reads doc, docx, odt, html, txt format etc.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
i tested this problem since 4.3 which is the first version that works with screen reader without need to install java until the last version supported on windows xp, (5.4.7).
nvda versions does not matter.
i use espeak as my tts and i only tested with persian documents.
i did not test with english files and dont know the result!
Comment 1 Timur 2020-06-23 18:20:05 UTC
(In reply to zahra from comment #0)
> since i use windows xp, the last version of libreoffice which i can test is
> 5.4.7, so, not sure about newer versions.
You may switch to Linux and use new LO. But if bug report is clear, someone here may test with new LO.

> i have a docx file.
Why DOCX? I guess it may also be ODT. Important is that you attach it, without personal info.

> most times nvda says blank.
> other times, read document in reverse order!
Hard to confirm for us that don't speak Persian. I can generally say that we have some bugs with text direction for RTL (right-to-left).

> Actual Results:
> i cant read pdf files, nvda reads them in the reverse order, even maybe
> libreoffice converts them to the picture instead of written pdf document.
It's not true, you should have verified that before reporting. 

> i did not test with english files and dont know the result!
It's important that you do, to know if this is some RTL or general LO issue.
Comment 2 zahra 2020-06-24 08:46:24 UTC
(In reply to Timur from comment #1)
> (In reply to zahra from comment #0)
> > since i use windows xp, the last version of libreoffice which i can test is
> > 5.4.7, so, not sure about newer versions.
> You may switch to Linux and use new LO. But if bug report is clear, someone
> here may test with new LO.
> 
> > i have a docx file.
> Why DOCX? I guess it may also be ODT. Important is that you attach it,
> without personal info.
> 
> > most times nvda says blank.
> > other times, read document in reverse order!
> Hard to confirm for us that don't speak Persian. I can generally say that we
> have some bugs with text direction for RTL (right-to-left).
> 
> > Actual Results:
> > i cant read pdf files, nvda reads them in the reverse order, even maybe
> > libreoffice converts them to the picture instead of written pdf document.
> It's not true, you should have verified that before reporting. 
> 
> > i did not test with english files and dont know the result!
> It's important that you do, to know if this is some RTL or general LO issue.

hello.
i downloaded one english pdf and tested it.
and i did not observe inverse reading of my screen reader.
however, pdf files and draw are not accessible for screen readers, if i am correct.
at least, i did not find a solution that i can read any pdf file with libreoffice with nvda screen reader!
i am blind and cant see the pictures.
but because nvda always says shape when i use one pdf file with libreoffice,
i thought that libreoffice converts text pdf files in to image to display them!
i dont know coding, i really cant use terminal, shell, command line etc.
and for this reason and other reasons that its difficult for me to explain them in english here, i really cant use linux and windows is the only operating system that i can use.
and i attach the docs file which i attached it in my description.
with the english file which i downloaded today to test.
Comment 3 zahra 2020-06-24 08:53:34 UTC
Created attachment 162365 [details]
the docx format of persian pdf file which i attached in my description
Comment 4 zahra 2020-06-24 08:55:50 UTC
Created attachment 162366 [details]
one english pdf file which i downloaded today
Comment 5 V Stuart Foote 2020-06-24 12:28:18 UTC
Exact dupe for Persian language of bug 115802, but the general case is mishandling of RTL text runs in the PDF generator. 

The mis-sounding by screen readers is just a symptom of the structural deficiencies of the PDF export where words or sentences of the text runs are treated LTR rather than RTL.

It affects Linux and Orca users, in addition to Windows NVDA (or JAWS) users as here.

@Thorston, ESC notes still show you have this under review. Any progress?

*** This bug has been marked as a duplicate of bug 104597 ***
Comment 6 Thorsten Behrens (CIB) 2020-06-24 12:46:17 UTC
(In reply to V Stuart Foote from comment #5)
> @Thorston, ESC notes still show you have this under review. Any progress?
> 

Not really - beyond the no-brainer of reverting the original 2013er change.