Bug 134265 - Marking comment as resolved doesn't get saved in DOCX format
Summary: Marking comment as resolved doesn't get saved in DOCX format
Status: RESOLVED DUPLICATE of bug 122222
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: dataLoss, filter:docx
Depends on:
Blocks: DOCX-Comments
  Show dependency treegraph
 
Reported: 2020-06-23 14:04 UTC by gahara31
Modified: 2021-04-13 06:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A sample with a comment (19.28 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-06-23 14:50 UTC, Mike Kaganski
Details
Sample DOCX with a comment resolved in MSO (20.46 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-06-23 16:02 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gahara31 2020-06-23 14:04:40 UTC Comment hidden (obsolete)
Comment 1 gahara31 2020-06-23 14:08:07 UTC
let me rephrase it to make it more clearer. 

comment made by other who use ms.word, when marked as resolve in writer and saved as .docx in writer doesn't stay resolved when the file re-opened in writer.
Comment 2 Mike Kaganski 2020-06-23 14:20:08 UTC
Ref: https://ask.libreoffice.org/en/question/251838

Please provide a sample DOCX with comments, which others could open in Writer, try to resolve and reopen. Thanks!
Comment 3 Mike Kaganski 2020-06-23 14:50:23 UTC
Confirm using Version: 6.4.5.1 (x64)
Build ID: be964ce243d03404cfeed53d0487f5d6bd49c627
CPU threads: 12; OS: Windows 10.0 Build 18363; UI render: GL; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: CL
Comment 4 Mike Kaganski 2020-06-23 14:50:42 UTC
Created attachment 162352 [details]
A sample with a comment
Comment 5 Timur 2020-06-23 16:02:47 UTC
Created attachment 162354 [details]
Sample DOCX with a comment resolved in MSO

This would be Filesave issue, but we also have Fileopen issue: 
if comment is marked Resolved in MSO, as attached, LO opens it without that mark.
Yes, that can be another issue, but let's first see what happens here. 

Looks like DOCX issue only, DOC cannot handle it in MSO.
Comment 6 Aron Budea 2020-09-27 14:19:06 UTC
*** Bug 137053 has been marked as a duplicate of this bug. ***
Comment 7 Buovjaga 2020-12-16 19:02:45 UTC
*** Bug 138930 has been marked as a duplicate of this bug. ***
Comment 8 Federico Kereki 2020-12-16 20:40:45 UTC
Check bug 138930 for sample files.
Comment 9 Mike Kaganski 2021-04-13 06:23:10 UTC

*** This bug has been marked as a duplicate of bug 122222 ***