Bug 134268 - Slow sorting of a column ( part 2 )
Summary: Slow sorting of a column ( part 2 )
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.4.0
Keywords: bibisected, bisected, perf, regression
Depends on:
Blocks:
 
Reported: 2020-06-23 16:14 UTC by Xisco Faulí
Modified: 2022-03-07 08:11 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Flamegraph (372.67 KB, image/svg+xml)
2021-12-13 20:36 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-06-23 16:14:54 UTC
Steps to reproduce:
1. Open attachment 161647 [details] from bug 133699
2. Click on top of column A -> A1:A1048576 is selected
3. Data - Sort Descending - Current Selection.

After https://git.libreoffice.org/core/commit/97965876459d8cfda0b653551708eb14de36e632 it takes 1 minute and 10 seconds for me

Reproduced in

Version: 7.1.0.0.alpha0+
Build ID: 10129e2dfc582915d999e24deed34f7303a6f02e
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-06-23 16:16:49 UTC
Regression introduced by:

author	Eike Rathke <erack@redhat.com>	2014-12-01 23:56:44 +0100
committer	Eike Rathke <erack@redhat.com>	2014-12-02 14:56:49 +0100
commit 6c2111f17089eb667bf526561d7667d17825e822 (patch)
tree 5ba7712d0325c1f048d1ffbb1c0053e36d2567be
parent f0c4cd51cb160492d78c2796f71ecd88da25fa59 (diff)
fdo#86762 re-establish listeners to move cell broadcasters

Bisected with: bibisect-50max

Adding Cc: to Eike Rathke

before the commit it takes 5 seconds to sort the commit. after, it takes 1 minutes 10 seconds
Comment 2 Xisco Faulí 2020-06-23 16:17:37 UTC
@Noel, since you fixed bug 133699 I thought you might also be interested in this issue...
Comment 3 Xisco Faulí 2021-12-13 12:38:10 UTC
it takes 17 seconds in

Version: 7.3.0.0.beta1+ / LibreOffice Community
Build ID: ecfb83d7463bed7c89baeccc03286c1ac9956d70
CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 4 Xisco Faulí 2021-12-13 12:44:07 UTC
@Julien, any change you could get a perf graph here?
Comment 5 Julien Nabet 2021-12-13 20:36:55 UTC
Created attachment 176917 [details]
Flamegraph

On pc Debian x86-64 with gen rendering + --enable-symbols I don't reproduce this.
It takes about 5 seconds on a Ryzen 2600 + 32GB

Remark: it's a brand new LO profile, so no experimental features enabled.
Comment 6 Commit Notification 2022-03-06 07:20:52 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/648a4b30b33569052847b797c38e52ba2fd2d500

do not destroy broadcasters and then recreate again (tdf#134268)

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Buovjaga 2022-03-07 08:11:31 UTC
Verified

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 66a9795f27fda887d9f66d0d8bb196fd636fe452
CPU threads: 8; OS: Linux 5.16; UI render: default; VCL: kf5 (cairo+xcb)
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded