Bug 134281 - Add a keyboard shortcut for pointer as pen
Summary: Add a keyboard shortcut for pointer as pen
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.4.4.2 release
Hardware: All All
: medium enhancement
Assignee: Gabor Kelemen (allotropia)
URL:
Whiteboard: target:7.2.0
Keywords:
: 119119 (view as bug list)
Depends on:
Blocks: Shortcuts-Accelerators
  Show dependency treegraph
 
Reported: 2020-06-24 12:58 UTC by paulatz
Modified: 2021-03-10 09:00 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Current help screen of the presenter console (2.61 MB, image/jpeg)
2021-01-11 17:18 UTC, Gabor Kelemen (allotropia)
Details
Modified help screen of the presenter console (2.55 MB, image/jpeg)
2021-01-11 17:21 UTC, Gabor Kelemen (allotropia)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description paulatz 2020-06-24 12:58:22 UTC
Description:
Using the "pointer as pen" function, in conjunction with a tactile screen, is very useful for remote lecturing.

However, it is a bit clumsy to use as it is not possible to activate this option, clear the ink from the slide, undo the drawing or change the ink color without going through a right-click context menu or dialog window.

Steps to Reproduce:
1. start presentation mode (F5)
2. right-click to activate pointer as pen mode
3. navigate several sub-menus for features

Actual Results:
Have a simple keyboard shortcut to activate pointer and pen, clear ink and rotate through a few colours

Expected Results:
as above


Reproducible: Always


User Profile Reset: Yes



Additional Info:
no
Comment 1 Buovjaga 2020-11-09 06:19:47 UTC
It is indeed not possible to assign it to anything. Let's ask UX team to be sure we should accept this.
Comment 2 Heiko Tietze 2020-11-09 12:10:45 UTC
My first idea was to use the presenter console but we neither have the pen there nor any context menu. But since several functions are activated per key, for example toggle screen black per B or white per W, we could introduce another key for the pen on/off and erase all. But keys are precious and all other tweaks are rather done per menu. If the presenter console is active a dedicated field would be handy, of course.
Comment 3 Heiko Tietze 2020-11-12 09:11:37 UTC
We discussed this topic in the design meeting and agree with the idea.

Since P and N are both used for previous/next slide but many alternatives allow the same, we suggest to drop these shortcuts and use P for pen on/off and E for erase all.
Comment 4 Gabor Kelemen (allotropia) 2021-01-11 17:18:03 UTC
Created attachment 168826 [details]
Current help screen of the presenter console
Comment 5 Gabor Kelemen (allotropia) 2021-01-11 17:21:45 UTC
Created attachment 168827 [details]
Modified help screen of the presenter console

Proposed patch:
https://gerrit.libreoffice.org/c/core/+/109108

Here I went with the proposed shortcuts, but it may worth reconsidering what bug #96867 suggested, the PowerPoint way:
Ctrl+p -> Draw Pen
Ctrl+e -> Eraser

This may be more familiar to people switching from PP.
Comment 6 Commit Notification 2021-02-02 08:25:40 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/5544c178975d480242151083d6c72d42b88a1db4

tdf#134281 [API-CHANGE] Add keyboard shortcut for UsePen and EraseInk

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Luke 2021-02-02 20:18:46 UTC
As a mixed Impress/PowerPoint user, this was a terrible decision. There are plenty of free keys to use, why break API's and compatibly with PowerPoint for this? We should use the same keys as PowerPoint or if that's not possible, use unassigned ones.
Comment 8 Heiko Tietze 2021-02-03 11:06:02 UTC
(In reply to Luke from comment #7)
> As a mixed Impress/PowerPoint user, this was a terrible decision. There are
> plenty of free keys to use, why break API's and compatibly with PowerPoint
> for this? We should use the same keys as PowerPoint or if that's not
> possible, use unassigned ones.

You probably talk about P/N for previous/next slide. There are plenty of (easier to tap) alternatives, and P is natural for Pen (and E for Erase). I think it's worth to randomly assign a key to a function than learning to use arrow keys.
Comment 9 Gabor Kelemen (allotropia) 2021-02-04 07:13:11 UTC
*** Bug 119119 has been marked as a duplicate of this bug. ***
Comment 10 NISZ LibreOffice Team 2021-03-10 09:00:32 UTC
Verified in:

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 72841008bf422dfd8553240b3a78f0474d03523c
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded Jumbo