Bug 134359 - Transparency or Transparency /slider not working
Summary: Transparency or Transparency /slider not working
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-28 10:55 UTC by Telesto
Modified: 2020-06-30 08:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (632.50 KB, application/vnd.oasis.opendocument.graphics)
2020-06-28 10:55 UTC, Telesto
Details
Proper example file (465.25 KB, application/vnd.oasis.opendocument.text)
2020-06-29 20:33 UTC, Telesto
Details
Real proper example (465.55 KB, application/vnd.oasis.opendocument.text)
2020-06-29 20:36 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-06-28 10:55:08 UTC
Description:
Transparency or Transparency /slider not working

Steps to Reproduce:
1. Open the attached file
2. Select the image
3. Drag the transparency slider

Actual Results:
Not working

Expected Results:
Should work


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 006c65bbd472cb1d7d44e095714e28190b76be0d
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: de-DE (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-06-28 10:55:25 UTC
Created attachment 162473 [details]
Example file
Comment 2 Telesto 2020-06-28 10:56:56 UTC
Fine in 
Version: 7.0.0.0.beta1+ (x64)
Build ID: 2891e91a513520d68ea2b8c59c14335861a15253
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 3 Xavier Van Wijmeersch 2020-06-28 15:21:55 UTC
can reproduce with

Version: 7.1.0.0.alpha0+
Build ID: e318e4cea37f6adb20cffc913655c0e6dbabe45a
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: nl-BE (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 4 Buovjaga 2020-06-29 14:55:55 UTC
Where can I find the transparency slider? I only have a transparency spinbox in the Sidebar Properties. It works just fine in Win (Skia or not), Linux (gtk3, kf5).
Comment 5 Telesto 2020-06-29 20:33:51 UTC
Created attachment 162523 [details]
Proper example file
Comment 6 Telesto 2020-06-29 20:36:20 UTC
Created attachment 162524 [details]
Real proper example
Comment 7 Telesto 2020-06-29 20:37:46 UTC
Image inserted in draw and copy/pasted into Writer (which makes the image a different object type something)
Comment 8 Buovjaga 2020-06-30 07:43:36 UTC
(In reply to Telesto from comment #7)
> Image inserted in draw and copy/pasted into Writer (which makes the image a
> different object type something)

So you're talking about the transparency of *the Area fill*. Why should the image transparency be affected by it?? The image is not there as a bitmap fill after all.
Comment 9 Xisco Faulí 2020-06-30 08:18:41 UTC
(In reply to Telesto from comment #2)
> Fine in 
> Version: 7.0.0.0.beta1+ (x64)
> Build ID: 2891e91a513520d68ea2b8c59c14335861a15253
> CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
> Locale: nl-NL (nl_NL); UI: en-US
> Calc: CL

Are you sure it worked back then? I've just tried with 

Version: 7.0.0.0.beta1+
Build ID: 2891e91a513520d68ea2b8c59c14335861a15253
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

( same commit ) and the transparency doesn't have any effect.
I believe you mean the transparency slider on the sidebar, isn't it ?
Comment 10 Telesto 2020-06-30 08:40:11 UTC
No, I somehow messed this up a bit.. didn't notice it was not a 'normal' image but copy/paste from Impress/Draw.
Comment 11 Buovjaga 2020-06-30 08:45:09 UTC
Ok, let's close as notabug