Download it now!
Bug 134395 - "Ctrl + Enter" Page Break is not acting as true page break
Summary: "Ctrl + Enter" Page Break is not acting as true page break
Status: RESOLVED DUPLICATE of bug 128616
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
: 135409 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-06-29 14:49 UTC by R. Green
Modified: 2020-08-03 13:57 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Writer file showing a page break issue (24.24 KB, application/vnd.oasis.opendocument.text)
2020-06-29 14:49 UTC, R. Green
Details

Note You need to log in before you can comment on or make changes to this bug.
Description R. Green 2020-06-29 14:49:31 UTC
Created attachment 162510 [details]
Writer file showing a page break issue

Version: 6.4.4.2 (x64)
Build ID: 3d775be2011f3886db32dfd395a6a6d1ca2630ff
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: default; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-GB
Calc: threaded

1. Open the attached file. Notice that the page style is "Chap 1". Page styles have been coloured to make viewing easier.
2. Enter a page break, anywhere in the text, directly from the INSERT menu OR using the shortcut Ctrl + Enter.

Actual/Expected result: A page break is entered and the Page Style after the break is also "Chap 1".

3. Now place the cursor after the page break and change the page style to "Chap 2".

EXPECTED RESULT: The page style after the break changes to "Chap 2" but the page style before the break remains as "Page 1".

ACTUAL RESULT. The page style after the page break changes to "Chap 2" (as expected) but so does the style BEFORE the page break.

NOTE: If you apply the page break using the "More Breaks > Manual Break" submenu, then a TRUE page break is created: i.e. if you change a page style after the break the page style before the break remains UNCHANGED—and vice versa.
Comment 1 Telesto 2020-06-29 16:52:45 UTC
Repro & agree
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 006c65bbd472cb1d7d44e095714e28190b76be0d
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

but lets ask UX to be sure
Comment 2 Telesto 2020-06-29 17:38:48 UTC
Also in
LibreOffice 3.5.7.2 
Build ID: 3215f89-f603614-ab984f2-7348103-1225a5b
Comment 3 V Stuart Foote 2020-06-29 18:03:15 UTC
WFM and NAB.  Working in a document with multiple Page Styles requires use of the Insert -> Manual Break to make the page style selection.

We do not expect <Ctrl>+<Enter> to do more than break for the currently active page style (often as drawn from the Default template), nor is it documented to do more--see the Tip item for the 'Page Break':

https://help.libreoffice.org/6.4/en-US/text/swriter/01/04010000.html?&DbPAR=WRITER
Comment 4 V Stuart Foote 2020-06-29 18:13:18 UTC
Should add that applying a Page style to a document stream without page style breaks inserted will apply to pages of the entire document, or if present to the contiguous pages in the current page style.

Typical to misconceptions of managing page styles as in bug 126608, but a basic facet of working with page style in ODF. 

Dev work on bug 41316 would be required to change page style behavior(s).
Comment 5 R. Green 2020-06-30 11:01:38 UTC
AFAICS, there are actually two different kinds of Page Break:

1. "Impermeable". A Page Style cannot cross the break. (Currently provided by the "Insert > More Breaks > Manual Break" option.)
 
2. "Permeable". A page style can cross the break. (Currently provided by the "Insert > Page Break" option.)

Perhaps a formatting mark could be introduced to show page breaks?
Comment 6 Heiko Tietze 2020-06-30 12:04:43 UTC
(In reply to R. Green from comment #5)
> Perhaps a formatting mark could be introduced to show page breaks?

There is a small blue dotted line when you manually break the page. Bug 128616 requests to make this indication more clear. Let's make this ticket a duplicate- unless you disagree.

*** This bug has been marked as a duplicate of bug 128616 ***
Comment 7 Mike Kaganski 2020-06-30 12:08:27 UTC
(In reply to V Stuart Foote from comment #3)
> WFM and NAB.  Working in a document with multiple Page Styles requires use
> of the Insert -> Manual Break to make the page style selection.
> 
> We do not expect <Ctrl>+<Enter> to do more than break for the currently
> active page style (often as drawn from the Default template), nor is it
> documented to do more--see the Tip item for the 'Page Break':

Absolutely support. (Just a nitpick: WFM is not applicable here: WFM means "yes, there was this problem; but at some point, it was fixed by unknown commit, so we mark it WFM, not FIXED, which is only used when fixing commit is known").
Comment 8 R. Green 2020-06-30 17:01:16 UTC
(In reply to Heiko Tietze from comment #6)
> There is a small blue dotted line when you manually break the page. Bug
> 128616 requests to make this indication more clear.
Never noticed that before. Agree, issue can be closed.
Comment 9 Telesto 2020-07-01 15:08:38 UTC
Sorry, still two remaining remarks/questions (to get some insight, and adding an alternative perspective)
1. open attachment 162510 [details]
2. Enter a page break, anywhere in the text, directly from the INSERT menu OR using the shortcut Ctrl + Enter.
3. Sidebar -> Page Styles -> 
4. Right Click Chap 1 Modify
5. Set next style to Chap 2

A. Is this result desired/expected.. I would say no based on comment 3/4.. But the page break/ manual break difference + page style is not something I really really understand.. 

B) Has LibreOffice a different conception of a "page break" compared to the competitors? So is this more or less a issue of terminology. I really associate page break + style as R. Green initial did. And if this is a common problem (poll?) it might be wise to 'rename' if this is different compared to 'normal'.. 

For the record: Point to help/tips etc. doesn't help much if someone diverges from a a common 'golden standard'.. with a kind of "read the f**king manual" approach (sorry that's what I read between the lines). Does not often convince me ;-). 
We could define dvorak keyboard position as 'standard' not matching the qwerty keyboard, because we are convinced  dvorak is just better.. and point to some help explaining things.. but not sure if people would accept it.. 

We are rather habitual kind (design and ux maybe which the could teach people, sometimes it works, but often backfires.. ). So conforming/ slowly moving to different direction/ or renaming (the last with risk of people complaining: where do I find the page break ;-). However the solution calling it a 'page break' but only being partial the same thing as commonly accepted is awful proposition too :-). Which even harder to explaining. The LibreOffice page break is something else.. Yes you see page breaks from imported DOCX files.. but still not the MS Office kind.. 

So call LibreOffice page breaks for example page holders.. not page breaks.. and insert them with CTRL+ENTER.. Ideally with the MS page break still around.. [Note: I didn't dive into MS Office to deep, so maybe i'm talking non-sense here :-)]

BTW, can the different kind of page breaks also get a different color, maybe (Or this to colorful (of course bit problematic for the color blind). And/or different type of dashes? Instead of only #.
Comment 10 Mike Kaganski 2020-07-01 15:34:05 UTC
LibreOffice page breaks are exactly page breaks, they break pages. No rename needed.

If a page break has additional property of starting a page style sequence is orthogonal. That is page break's property. Normally page breaks are just manual breaks that don't differ from automatic page breaks, except they are put manually - user is not satisfied by automatic breaking. It's absolutely same as line break inside paragraphs - they insert a break in a different place than would happen automatically, nothing else.

Competitors don't have page style concept at all. It's their shortage, and they abuse page break concept to also mean something unrelated - starting sections, etc.
Comment 11 V Stuart Foote 2020-07-01 15:36:16 UTC
(In reply to Mike Kaganski from comment #10)

+1, you beat me to it...
Comment 12 Heiko Tietze 2020-08-03 13:57:48 UTC
*** Bug 135409 has been marked as a duplicate of this bug. ***