Bug 134396 - Sidebar: adding any image from the gallery will always add the first
Summary: Sidebar: adding any image from the gallery will always add the first
Status: RESOLVED DUPLICATE of bug 134285
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-06-29 15:00 UTC by Gerald Pfeifer
Modified: 2020-06-29 18:13 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer 2020-06-29 15:00:14 UTC
How to reproduce:

 1. Open any presentation.
 2. Open the sidebar and move to the gallery tab.
 3. Drag and drop the first image in the gallery shown somewhere into the slide.
 4. Drag and drop any other image (than the first) in the gallery into the slide.
 5. Observe how in both cases the first image was copied, regardless of which
    one you chose in the gallery.

The user originally reporting this via openSUSE created a nice demo video:

  https://bugzilla.suse.com/attachment.cgi?id=839133

I reproduced this with

 Version: 7.1.0.0.alpha0+
 Build ID: 3ba009e0c2b7800305103f8ec86df58625fed955
 CPU threads: 4; OS: Linux 5.6; UI render: default; VCL: gtk3
 Locale: en-US (en_US.UTF-8); UI: en-US
 TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-06-25_05:32:26

as well as LibreOffice 7.0 beta, alas not with 6.4.4.2.
Comment 1 Xisco Faulí 2020-06-29 15:46:07 UTC
Reproduced in

Version: 7.1.0.0.alpha0+
Build ID: 42bf9bdf3d551eb59604f952204c49f7d7a1e913
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

bisecting
Comment 2 Xisco Faulí 2020-06-29 15:52:21 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=23a1b7bad5147ee48d7f920085426d8846559af7

author	Caolán McNamara <caolanm@redhat.com>	2020-05-15 14:54:58 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2020-05-15 17:27:10 +0200
commit	23a1b7bad5147ee48d7f920085426d8846559af7 (patch)
tree	c8ea9636d9f2a6830d1cd3e5ffa6c55b82834f1c
parent	f0ca5a0c447f4fe4667693d744af61eaeb0625ee (diff)
Resolves: tdf#132461 set color on mouse release, not press

Bisected with: bibisect-linux64-7.0

Adding Cc: to Caolán McNamara
Comment 3 Caolán McNamara 2020-06-29 18:13:49 UTC

*** This bug has been marked as a duplicate of bug 134285 ***