Bug 134405 - Crash when tapping odp slideshow, if experimental mode enabled.
Summary: Crash when tapping odp slideshow, if experimental mode enabled.
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Android Viewer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Michael Weghorn
URL:
Whiteboard: target:7.1.0
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-29 23:35 UTC by baffclan
Modified: 2020-07-04 02:50 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Another sample doc (13.52 KB, application/vnd.oasis.opendocument.presentation)
2020-07-01 14:14 UTC, Michael Weghorn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description baffclan 2020-06-29 23:35:28 UTC
Description:
Crash when tapping odp slideshow, if experimental mode enabled.

Steps to Reproduce:
1. experimental mode enabled, and restart
2. open mytest.odp ( attachment 139890 [details] / bug 115706)
3. tap a slideshow


Actual Results:
crash a LibreOffice Viewer


Expected Results:
Zoom or next slide



Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ / Android-ARM@86-TDF.
Builed ID: 4f915b6
Comment 1 Michael Weghorn 2020-06-30 05:29:32 UTC
Confirmed with

Version 7.1.0.0.alpha0+
Build ID: 3ba009e
on an x86 AVD
Comment 2 Michael Weghorn 2020-07-01 14:14:49 UTC
Created attachment 162561 [details]
Another sample doc

Same crash happens when opening this sample doc and just clicking into the title area.
Comment 3 Michael Weghorn 2020-07-01 14:17:01 UTC
Pending fix: https://gerrit.libreoffice.org/c/core/+/97632
Comment 4 Commit Notification 2020-07-01 18:17:21 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/03093a91b64fea9852704f49cd20d162784ca748

tdf#134405 android: Add null check

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 baffclan 2020-07-04 02:50:23 UTC
Cannot reproduce with Newest LibreOffice Viewer.

Android-ARM@86-TDF / 2020-07-02_15.32.14
Version: 7.1.0.0.alpha0+
BuildID: 441af1f

Thanks for fixing this!