Download it now!
Bug 134431 - CRASH: pasting content twice
Summary: CRASH: pasting content twice
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:7.1.0 target:7.0.0.2 target:6.4.6
Keywords: bibisected, bisected, regression
: 134700 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-07-01 10:24 UTC by Xisco Faulí
Modified: 2020-07-14 14:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-07-01 10:24:31 UTC
Steps to reproduce:
1. Open attachment 155681 [details] from bug 124821
2. Select all
3. Cut
4. Paste 2 times

Reproduced in

Version: 7.1.0.0.alpha0+
Build ID: 7df1884118a0d995ec57679ef83e586c95063858
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-07-01 10:25:16 UTC
Reproduced in

author	Miklos Vajna <vmiklos@collabora.com>	2020-06-29 21:05:27 +0200
committer	Miklos Vajna <vmiklos@collabora.com>	2020-06-30 09:28:31 +0200
commit	682e0488df819c191c13a03758fad0690706e508 (patch)
tree	c1cc1d39f8317f9b10ee55d0e9936dfa0511c6d5
parent	ca1df564c3199a569c681d5814e1fddc66c48522 (diff)
tdf#134099 sw: fix textbox anchors on copy-paste and undo

Bisected with: bibisect-linux64-7.1

Adding Cc: to Miklos Vajna
Comment 2 Xisco Faulí 2020-07-10 16:25:43 UTC
*** Bug 134700 has been marked as a duplicate of this bug. ***
Comment 3 Commit Notification 2020-07-14 07:02:56 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9c8aa11ee7ddbae34afcce2cbfc4d521122a527b

tdf#134431 sw: fix crash on setting anchor of textbox while splitting a para

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2020-07-14 10:30:27 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/ebbb27eb3970fd9409cbf8b38088620d5132e070

tdf#134431 sw: fix crash on setting anchor of textbox while splitting a para

It will be available in 7.0.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2020-07-14 13:59:41 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/ee7e551c865c8a36e1ef99d4d68dfa54ba5316d8

tdf#134431 sw: fix crash on setting anchor of textbox while splitting a para

It will be available in 6.4.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2020-07-14 14:36:52 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: 616a47c9570f9ce67b18a124f08f4a342bff3468
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Miklos, thanks for fixing this issue!!