Download it now!
Bug 134434 - BigPtrArray::Index2Block freeze
Summary: BigPtrArray::Index2Block freeze
Status: RESOLVED DUPLICATE of bug 134101
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha0+
Hardware: All All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Crash-BigPtrArray
  Show dependency treegraph
 
Reported: 2020-07-01 11:40 UTC by Telesto
Modified: 2020-07-07 16:56 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
GDB trace of crash (47.73 KB, text/plain)
2020-07-04 15:14 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-07-01 11:40:00 UTC
Description:
BigPtrArray::Index2Block freeze

Steps to Reproduce:
1. Open attachment 157040 [details]
2. CTRL+A
3. CTRL+C
4. CTRL+N
5. CTRL+V
6. CTRL+Z -> Hang or crash

Could be a duplicate.. I have reported similar freeze before

Actual Results:
Freeze for me; or crash it should crash. stuck in BigPtrArray::Index2Block

Expected Results:
No freeze no crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 4c14c88cc681abab787a461a1bea502a777f37e6
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-07-01 11:44:53 UTC
Maybe related
1. Open attachment 157040 [details]
2. CTRL+A
3. CTRL+X
4. CTRL+Z
5. CTRL+Y -> Mess on the first page
Comment 2 Buovjaga 2020-07-04 15:14:26 UTC
Created attachment 162633 [details]
GDB trace of crash

Arch Linux 64-bit
Version: 7.1.0.0.alpha0+
Build ID: 777f9cec0985f99451ecb804d5ae139a0be32253
CPU threads: 8; OS: Linux 5.7; UI render: default; VCL: kf5
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 4 July 2020
Comment 3 Buovjaga 2020-07-04 15:15:37 UTC
Already in 6.4
Comment 4 Telesto 2020-07-04 16:17:58 UTC
Source bugdoc bug 75208
Comment 5 Telesto 2020-07-04 16:18:55 UTC
No crash with
Version: 6.0.5.0.0+
Build ID: 15ea1cda0b3c37ff944ad9a239b7ed453e8b0591
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 6 Buovjaga 2020-07-04 19:18:33 UTC
There are multiple phases in the evolution. During 7.0, it changed from the crash happening at step 3. CTRL+C to the one in the description. This change is https://git.libreoffice.org/core/+/cf226535f9903a048b1c105b180ae3a50a776e68%5E!/
tdf#129805 writerfilter: fix import of nested generic field

During 6.4, it changed from OK to crashing upon exit after the steps in the description. This change is https://git.libreoffice.org/core/+/5ba30f588d6e41a13d68b1461345fca7a7ca61ac%5E!/
tdf#64222 sw: better DOCX import/export of paragraph marker formatting

Both commits touch DomainMapper.

Bibisects done on Linux.

Adding Cc: to Michael Stahl
Comment 7 Michael Stahl (CIB) 2020-07-07 16:56:47 UTC
a strange sense of deja vu ... ah right that's even basically the same document...

*** This bug has been marked as a duplicate of bug 134101 ***