Download it now!
Bug 134442 - Problem with page break editing when page break is specified in the following paragraph
Summary: Problem with page break editing when page break is specified in the following...
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-01 17:09 UTC by R. Green
Modified: 2020-07-03 11:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Writer page break problem (18.96 KB, application/vnd.oasis.opendocument.text)
2020-07-01 17:09 UTC, R. Green
Details
Screen cast (728.87 KB, image/gif)
2020-07-03 09:33 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description R. Green 2020-07-01 17:09:25 UTC
Created attachment 162566 [details]
Writer page break problem

Version: 6.4.4.2 (x64)
Build ID: 3d775be2011f3886db32dfd395a6a6d1ca2630ff
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: default; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-GB
Calc: threaded

1. Open the attached file. Inspect the "Heading 1" paragraph style, and confirm on the "Text Flow" tab that a "page break before" is specified.

2. Bring up the "Edit page break" dialogue on the page break (blue dotted line). Go to the "Text Flow" tab. Check "With page style" and select "Chap 3". Press OK.

EXPECTED RESULT: P2 page style changes to "Chap 3"; P1 page style remains unchanged.
ACTUAL RESULT: ALL pages change to "Chap 3".

3. Bring up the "Edit page break" dialogue again and inspect the "Text Flow" tab.

RESULT (unexpected): The "With page style" line has been reset.

AFAICS, there are actually two different types of page break:

(1) "HARD" page break: Page styles on opposite sides of the break can be changed independently of one another.

(2) "SOFT" page break: Page styles flow across the break.

IMV, the interface should allow the user to freely change one type of break ("Hard" or "Soft") to the other.
Comment 1 Regina Henschel 2020-07-01 21:04:13 UTC
I cannot confirm it. After step 2 the second page is pink and has page style 'Chap 3', and the first page is yellow and has page style 'Chap 1'.
Comment 2 Heiko Tietze 2020-07-02 10:10:53 UTC
In what form is this ticket different to bug 134395?
Comment 3 R. Green 2020-07-02 11:01:47 UTC
Version: 6.4.4.2 (x64)
Build ID: 3d775be2011f3886db32dfd395a6a6d1ca2630ff
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: default; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-GB
Calc: threaded

(In reply to Regina Henschel from comment #1)
> I cannot confirm it. After step 2 the second page is pink and has page style
> 'Chap 3', and the first page is yellow and has page style 'Chap 1'.
I've downloaded and rechecked the file and can definately replicate the issue in this version.
Comment 4 R. Green 2020-07-02 11:35:22 UTC
(In reply to Heiko Tietze from comment #2)
> In what form is this ticket different to bug 134395?
Bug 134395 wasn't a fully-informed report since I wasn't aware of the existence of a "Edit Page Break" dialogue; nor was it specifically about page breaks created in paragraph styles.
Comment 5 Heiko Tietze 2020-07-03 09:33:49 UTC
Created attachment 162604 [details]
Screen cast

* bug 134439 Page Break: editing "Text flow > Breaks" leads to page style being assigned to wrong page
(you expect the new PS on the following page claiming the PS affects the previous page)
* this bug 134442 Problem with page break editing when page break is specified in the following paragraph
(you expect the new PS on the following pages claiming all pages change)
* bug 134440 Page break editing: "Text Flow > Breaks" needs clearer wording
(discussing a clear wording based on the assumption of a wrong behavior)

In fact, changing the PS after the first page affects the second page (see also comment 1). I also cannot confirm your bug 134439 neither this one.
Comment 6 R. Green 2020-07-03 10:49:36 UTC
Thanks for the screencast, which was helpful. My original bug report was done using a mouse. When I repeat the operation using the touch pad and keyboard ONLY, I do indeed get the correct result (i.e. as shown in the screencast). 

Although my mouse is intermittently defective—the left-click occasionally double-clicks—it is curious that this problem occurs EVERY time without fail when using the "Edit Page Break" dialogue, and not with other LibreOffice operations.

So, IMV, it would be worth double-checking to make sure that there isn't some other reason for this difference between mouse-only operation and touchpad- + keyboard-only operation.

Otherwise, apologies for the duff report, and feel free to close the issue.
Comment 7 R. Green 2020-07-03 11:36:12 UTC
Ignore the previous post: it's a red herring. The actual cause of the issue is that editing "Text Flow > Breaks" gives differing results depending on where the cursor is originally "parked".  This is the same issue as Bug 134439 where it is fully explained.

This issue can be closed.