Bug 134453 - UI: Show the setting for all (available) applications integrally tools options instead of context dependent
Summary: UI: Show the setting for all (available) applications integrally tools option...
Status: RESOLVED DUPLICATE of bug 101609
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2020-07-01 21:04 UTC by Telesto
Modified: 2020-07-01 22:37 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-07-01 21:04:00 UTC
Description:
Show the setting for all (available) applications integrally tools options instead of context dependent

Steps to Reproduce:
1. Launch LibreOffice start centre
2. Tools -> Options

Actual Results:
No writer/calc/impress options
Except for the best supported app Base ;-)

Expected Results:
All stuff available..  I don't see the benefit of all the contextual stuff


Btw, also for writer, impress.. all other setting are shared anyhow


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha1
Build ID: 6a03b2a54143a9bc0c6d4c7f1...
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; VCL: osx; 
Locale: nl-NL (nl_NL.UTF-8); UI: en-US
Calc: threaded
Comment 1 Mike Kaganski 2020-07-01 21:26:36 UTC
That had changed between OOn 1.0 and 2.2. In 1.0.3 it displayed the full list of modules.

Ref.: https://bz.apache.org/ooo/show_bug.cgi?id=21962 (with rationale and specs).

Disclaimer: I don't mean that this suggestion should not be implemented (personally I support showing everything). The information is FYI.
Comment 2 Maxim Monastirsky 2020-07-01 22:37:14 UTC

*** This bug has been marked as a duplicate of bug 101609 ***