Download it now!
Bug 134482 - pdf export of odt file contains images but no text
Summary: pdf export of odt file contains images but no text
Status: RESOLVED DUPLICATE of bug 125234
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.4.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2020-07-03 14:28 UTC by david
Modified: 2020-07-04 21:12 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description david 2020-07-03 14:28:44 UTC
Description:
Using Version: 6.4.3.2 in Lubuntu 20.04 (a new installation) no text appears in the exported pdf file, although images appear in the correct places. I can't find a similar report on this site, although there is a report in 'https://ask.libreoffice.org/en/question/252543/writer-export-to-pdf-has-no-text/'. 

That link gives a work-around 'env SAL_USE_VCLPLUGIN=gen libreoffice &', but I've labelled this as normal severity because the work-around isn't appropriate for non-technical users



Steps to Reproduce:
1.Create .odt file in v 6.4.3.2 on Lubuntu 20.04
2.Export to pdf
3.

Actual Results:
No text in .pdf file, although images appear positioned correctly

Expected Results:
Included the text!


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.4.4.2
Build ID: 1:6.4.4-0ubuntu0.20.04.1
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: qt5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Roman Kuznetsov 2020-07-03 20:36:26 UTC
no problem in

Версия: 6.4.0.3
ID сборки: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
Потоков ЦП: 4; ОС: Linux 5.5; Отрисовка ИП: по умолчанию; VCL: kf5; 
Локаль: ru-RU (ru_RU.UTF-8); Язык интерфейса: ru-RU
Calc: threaded

nor in

Version: 7.0.0.1.0+
Build ID: 30ea3ba86b110db68c19815c5c67d4d315c091bf
Потоков ЦП: 4; ОС: Linux 5.5; Отрисовка ИП: по умолчанию; VCL: kf5
Locale: ru-RU (ru_RU.UTF-8); ИП: ru-RU
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-7-0, Time: 2020-07-03_04:42:21
Calc: threaded

possibly only vcl:qt5 or Lubuntu build problem
Comment 2 david 2020-07-04 13:43:11 UTC
I believe that this is related to bug 125234, reported in May 2019. It's also listed as a bug on the Lubuntu 20.04 release web page, https://lubuntu.me/focal-released/, where a different workaround is suggested, opening LibreOffice from a command line using Cairo (but that works only for creating new documents; trying to open an existing document with that workaround either messes up the screen, or else crashes completely.)

So this problem does seem to be related to the use of qt5 by the LXQt desktop, which of course is the default (and selling point) of Lubuntu 20.04.
Comment 3 Timur 2020-07-04 21:12:04 UTC
Similar reports were also marked duplicate.

*** This bug has been marked as a duplicate of bug 125234 ***