Bug 134509 - FILEOPEN DOCX: Text behind image (confirmed MSWord layout bug)
Summary: FILEOPEN DOCX: Text behind image (confirmed MSWord layout bug)
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks: DOCX-Images DOCX-Anchor-and-Text-Wrap
  Show dependency treegraph
 
Reported: 2020-07-04 19:52 UTC by Telesto
Modified: 2021-08-11 05:51 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (357.84 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-07-04 19:52 UTC, Telesto
Details
Second example (357.79 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-07-04 20:16 UTC, Telesto
Details
ODT from DOCX with same flaw (373.29 KB, application/vnd.oasis.opendocument.text)
2020-07-05 07:51 UTC, Telesto
Details
Comparison MSO 2010 and LibreOffice 7.1 master (389.87 KB, image/png)
2020-07-16 10:36 UTC, Xisco Faulí
Details
Comparison LibO 7.1 and LibO 3.3.0 (242.36 KB, image/png)
2020-08-03 18:51 UTC, Thomas Lendo QA
Details
attachment #162642 in Word 2013 and current 7.2master (472.35 KB, image/png)
2020-12-11 08:58 UTC, NISZ LibreOffice Team
Details
The fist example file after manually changing horizontal positioning (228.98 KB, image/png)
2020-12-11 09:01 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-07-04 19:52:43 UTC
Description:
FILEOPEN DOCX: Text behind image

Steps to Reproduce:
1. Open the attached file ->  Text hidden behind blue square

Actual Results:
Text hidden behind blue square

Expected Results:
Probably not.. but this a back and forward bug.. fine in 6.0/6.1/6.2/6.3. broken in 5.4


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: c48e4d795e37f23b71d647247590807ab9e52223
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-07-04 19:52:56 UTC
Created attachment 162642 [details]
Example file
Comment 2 Telesto 2020-07-04 20:16:17 UTC
Created attachment 162644 [details]
Second example

1. Open the file
2. Click the dark blue shape
3. press arrow up/down -> notice text added at last page

Broken 
Version: 7.1.0.0.alpha0+ (x64)
Build ID: c48e4d795e37f23b71d647247590807ab9e52223
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

broken in
Version: 6.4.0.0.beta1+ (x64)
Build ID: 20be5cd0bdc57d812bf34a2debfe48caa51de881
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL


Fine in
Version: 6.3.0.0.beta1+ (x86)
Build ID: 5cfac16dbd4af456a7fb6d52c8953c69a72ba2ba
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL

Fine in
Version: 6.1.0.0.alpha0+
Build ID: 2e4805442a9eeedb32d6b570c4c11594aca7c642
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: nl-NL (nl_NL); Calc: CL


Again different in 
6.0

Broken like 7.1 in
4.4.7.2

but not in
Versie 4.0.0.3 (Bouw-id: 7545bee9c2a0782548772a21bc84a9dcc583b89)
Comment 3 Telesto 2020-07-04 20:21:20 UTC Comment hidden (obsolete)
Comment 4 Telesto 2020-07-05 07:51:45 UTC Comment hidden (obsolete)
Comment 5 Telesto 2020-07-05 08:09:23 UTC
(In reply to Telesto from comment #4)
> Created attachment 162652 [details]
> ODT from DOCX with same flaw

With looks dependent on zoomlevel and some bad luck. in 80% of the cases it or opens with 7 pages or correct itself after scrolling to 7
Comment 6 Justin L 2020-07-14 12:18:35 UTC
Looks like just a layout issue. (just == an unsolvable problem)
Comment 7 Xisco Faulí 2020-07-16 10:36:17 UTC
Created attachment 163110 [details]
Comparison MSO 2010 and LibreOffice 7.1 master
Comment 8 Xisco Faulí 2020-07-16 10:36:38 UTC
Reproduced in

Version: 7.1.0.0.alpha0+
Build ID: d851a02df57ab378ed0cc6d9362516de09c3279c
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 9 Xisco Faulí 2020-07-16 10:39:10 UTC
Also reproduced in

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

thus, not a regression
Comment 10 Thomas Lendo QA 2020-08-03 18:51:36 UTC
Created attachment 163912 [details]
Comparison LibO 7.1 and LibO 3.3.0

Changing version to LibO 3.3.0 as also this version looks not like MSO. Presumably it's inherited from OOo.

Would be interesting to know how the objects are anchored into the page in MSO.
Comment 11 NISZ LibreOffice Team 2020-12-02 09:27:58 UTC
This started to look like today in 6.3 with:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=fa10258d723a0c50941166ba13274308fb0cfcbe

author	Miklos Vajna <vmiklos@collabora.com>	2019-03-04 21:24:58 +0100
committer	Miklos Vajna <vmiklos@collabora.com>	2019-03-05 08:35:02 +0100

tdf#123243 DOCX import: make increased anchored obj spacing cond more strict

Before this the document started with an extra empty page, but the two images appeared correctly after that.
Comment 12 Miklos Vajna 2020-12-02 09:33:01 UTC
In the context of the above commit, need to make sure that testing is done with MSO 2013 or newer. Older versions don't have that layout bug and LO is in sync with the Word 2013+ layout behavior, not with the older one.

Also, I would be really careful to extend that awful hack on our side even more: rather I would like to see them fix their layout bug. It's the single Word layout bug I got confirmed in the past several years. :-)
Comment 13 NISZ LibreOffice Team 2020-12-11 08:58:01 UTC
Created attachment 168045 [details]
attachment #162642 [details] in Word 2013 and current 7.2master

Still a problem in:

Version: 7.2.0.0.alpha0+ (x64)
Build ID: 61d07657caab5e0fb8ec4446f67a7044e14dae4b
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: en-US (hu_HU); UI: en-US
Calc: CL

Also: this file looks the same in Word 13 as in Word 10 on attachment #163110 [details]
Comment 14 NISZ LibreOffice Team 2020-12-11 09:01:38 UTC
Created attachment 168047 [details]
The fist example file after manually changing horizontal positioning

However, changing the horizontal positioning of both images from "Paragraph area" to "Left paragraph border" restores the original layout.

See bug #138782 about this.