Bug 134515 - FORMATTING, EDITING: Librecalc text-color-selector resets every time you insert a comment
Summary: FORMATTING, EDITING: Librecalc text-color-selector resets every time you inse...
Status: RESOLVED DUPLICATE of bug 113433
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Color-Picker-Widget
  Show dependency treegraph
 
Reported: 2020-07-04 23:54 UTC by Am Jam
Modified: 2020-08-11 18:31 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Am Jam 2020-07-04 23:54:02 UTC
Description:
Librecalc text-color-selector (the little icon with the letter "a" that lets you select what color your text is in a cell) resets to red every time you insert a comment.

Steps to Reproduce:
1. Enter text into Cell A1
2. Color the contents of Cell A1 any color not red (say, for example, green)
3. Insert a comment in any cell on the spreadsheet

Actual Results:
The text-color-selector reverts back to red.

Expected Results:
The text-color-selector stays green. I expect the text-color-selector to remain at the color that I set it to, and only change when I explicitly ask it to. 


Reproducible: Always


User Profile Reset: Yes



Additional Info:
N/A
Comment 1 Abhi 2020-08-03 16:17:59 UTC
Thanks you for reporting this bug. I can not reproduce this bug in:

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 5f665a855ef26fae4dfa2ac427685b60545e8b8
CPU threads: 16; OS: Windows 10.0 Build 18363; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL
Comment 2 Roman Kuznetsov 2020-08-11 17:59:13 UTC
confirm in

Version: 7.1.0.0.alpha0+ (x64)
Build ID: <buildversion>
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Vulkan; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: CL
Comment 3 Maxim Monastirsky 2020-08-11 18:31:10 UTC
This is a global problem that color buttons do not remember the last used color when the toolbar containing them is closed (when inserting a comment the "Formatting" toolbar is closed, and replaced by the "Text Formatting" toolbar). Same underlying issue as in Bug 113433, so let's keep them together.

*** This bug has been marked as a duplicate of bug 113433 ***