Bug 134542 - LibreOffice 6.4.5.2 doesn't recognize tabs/indents in RTFs
Summary: LibreOffice 6.4.5.2 doesn't recognize tabs/indents in RTFs
Status: RESOLVED DUPLICATE of bug 134548
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.beta1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectNotNeeded, regression
Depends on:
Blocks:
 
Reported: 2020-07-06 04:35 UTC by Robio
Modified: 2020-10-17 20:04 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Document to demonstrate the bug (6.71 KB, text/rtf)
2020-07-06 04:36 UTC, Robio
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robio 2020-07-06 04:35:27 UTC
Description:
Just downloaded 6.4.5.2 update, and now in every RTF I open, any line that begins with tabs/indents is flush left. The tabs/indents are ignored.

If I save the document as an ODF, the tabs/indents do appear.

Example document attached.

Steps to Reproduce:
1.Open attached document
2.Details are explained there
3.

Actual Results:
All tabs/indents at the beginning of a line are ignored, and the content of that line is flush left instead

Expected Results:
tabs/indents should behave normally


Reproducible: Always


User Profile Reset: No



Additional Info:
Treated tabs/indents normally
Comment 1 Robio 2020-07-06 04:36:54 UTC
Created attachment 162678 [details]
Document to demonstrate the bug
Comment 2 Robert Großkopf 2020-07-06 09:57:01 UTC
Could it be the same bug as https://bugs.documentfoundation.org/show_bug.cgi?id=134548 ?
Seems the version is wrong here ...
Comment 3 Robert Großkopf 2020-07-06 10:07:43 UTC
I can't confirm this is a special *.rtf-bug, but a bug with tabs since LO 6.4.5.2. Have set this bug to version 7.0.0.0.beta1, because the bug doesn't appear in LO 6.4.4.2.

Tested all with different versions on OpenSUSE 15.1 64bit rpm Linux.
LO 6.4.5.2 and LO 7.0.0.0.beta2 will show the buggy behavior.
LO 6.4.4.2 won't show it.

Wen I save the attached document as *.odt the tabs aren't visible after reopening the *.odt here.
Comment 4 Aron Budea 2020-10-17 20:04:49 UTC
Yep, seems so, and seems fixed, let's mark as duplicate.

If you find that a bug is a regression, please add keywords 'regression' and 'bibisectRequest' in the future.

*** This bug has been marked as a duplicate of bug 134548 ***