Download it now!
Bug 134548 - FILEOPEN: Tabulator, set after a number, disappears
Summary: FILEOPEN: Tabulator, set after a number, disappears
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Vasily Melenchuk (CIB)
URL:
Whiteboard: target:7.1.0 target:7.0.0.2 target:6.4.6
Keywords: bibisected, bisected, regression
: 134542 134859 134942 (view as bug list)
Depends on:
Blocks: DOCX-Bullet-Number-Outline-Lists
  Show dependency treegraph
 
Reported: 2020-07-06 08:05 UTC by Robert Großkopf
Modified: 2020-10-17 20:04 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Open the file in LO 6.4.4.2 and then in LO 6.4.5.2 - tab disappears (9.00 KB, application/vnd.oasis.opendocument.text)
2020-07-06 08:05 UTC, Robert Großkopf
Details
Shows the right content of LO 6.4.4.2 as *.pdf-file (9.68 KB, application/pdf)
2020-07-06 08:06 UTC, Robert Großkopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2020-07-06 08:05:47 UTC
Created attachment 162686 [details]
Open the file in LO 6.4.4.2 and then in LO 6.4.5.2 - tab disappears

Open the attached *.pdt-file.
There will be two numbered rows.
Second row will show a tab after the number and the other content if you open the file with LO 6.4.4.2 on OpenSUSE 15.1 64bit rpm Linux.

This tabulator will disappear with LO 6.4.5.2 and also with LO 7.0.0.0beta2.
I couldn't choose one of this versions, so I have choosen LO 7.0.0.0beta1. Could be the bug doesn't appear in this version ...
Comment 1 Robert Großkopf 2020-07-06 08:06:31 UTC
Created attachment 162687 [details]
Shows the right content of LO 6.4.4.2 as *.pdf-file
Comment 2 Telesto 2020-07-06 15:28:27 UTC
Repro with
Version: 7.1.0.0.alpha0+ (x64)
Build ID: c48e4d795e37f23b71d647247590807ab9e52223
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 3 Telesto 2020-07-09 12:41:38 UTC Comment hidden (obsolete)
Comment 4 Xisco Faulí 2020-07-09 13:10:12 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=d2e428d1abb9f2907c0b87d55830e8742f8209b9

author	Vasily Melenchuk <vasily.melenchuk@cib.de>	2020-05-29 14:25:04 +0300
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2020-06-05 01:11:11 +0200
commit	d2e428d1abb9f2907c0b87d55830e8742f8209b9 (patch)
tree	212a329c70a0e1377f7a5b1d15b510a96ecdc463
parent	c148ba2b18d42733587fbf169a08f9469daed8fe (diff)
tdf#83309: docx import: allow for lists tabstop at zero position

Bisected with: bibisect-linux64-7.1

Adding Cc: to Vasily Melenchuk
Comment 5 Telesto 2020-07-09 13:17:49 UTC
@Xisco
Priority was based on being backported into 6.4.5!! Should be solved before 6.4.6
Comment 6 Commit Notification 2020-07-10 20:24:51 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/da91b2fd8e7c980973240340c3cdfcd473c1b233

tdf#134548: sw: revert of changes to tab at zero pos

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2020-07-11 17:44:54 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/41d06c9ca1f4381691d822cbf97bdb17eda716fa

tdf#134548: sw: revert of changes to tab at zero pos

It will be available in 7.0.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2020-07-12 19:52:43 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/677f0cc64d124c42c98db0636c9cb295b28a9a29

tdf#134548: sw: revert of changes to tab at zero pos

It will be available in 6.4.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Xisco Faulí 2020-07-13 09:52:31 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: 00be56d9db396d284f66ab723d6fbb898b888dfb
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Vasily, thanks for fixing this issue!!
Comment 10 Christian Hartmann 2020-07-15 11:00:27 UTC
appeared first with 6.4.5.2 with all *.odt documents created myself in earlier versions.

Fix verified in:
Version: 7.0.0.1
Build: 04ba7e3f1e51af6c5d653e543a620e36719083fd
Locale: en
OS: Linux

thx a lot! best regards
Comment 11 Telesto 2020-07-16 17:52:47 UTC
*** Bug 134859 has been marked as a duplicate of this bug. ***
Comment 12 Telesto 2020-07-19 08:31:05 UTC
*** Bug 134942 has been marked as a duplicate of this bug. ***
Comment 13 Aron Budea 2020-10-17 20:04:49 UTC
*** Bug 134542 has been marked as a duplicate of this bug. ***