Bug 134550 - FILEOPEN: Large Spreadsheet Experimental XLSX Crash in: ScBroadcastAreaSlotMachine::StartListeningArea(ScRange const &,bool,SvtListener *)
Summary: FILEOPEN: Large Spreadsheet Experimental XLSX Crash in: ScBroadcastAreaSlotMa...
Status: RESOLVED DUPLICATE of bug 109061
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks: Calc-large-spreadsheets
  Show dependency treegraph
 
Reported: 2020-07-06 08:51 UTC by kevinpr
Modified: 2022-02-14 10:02 UTC (History)
5 users (show)

See Also:
Crash report or crash signature: ["ScBroadcastAreaSlotMachine::StartListeningArea(ScRange const &,bool,SvtListener *)"]
Regression By:


Attachments
Very big XLSX speadsheet file (11.92 MB, application/x-zip-compressed)
2020-07-06 08:51 UTC, kevinpr
Details
bt with debug symbols (12.19 KB, text/plain)
2020-07-06 11:30 UTC, Julien Nabet
Details
bt with debug symbols (19.17 KB, text/plain)
2021-05-03 19:10 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kevinpr 2020-07-06 08:51:38 UTC
Created attachment 162688 [details]
Very big XLSX speadsheet file

This bug was filed from the crash reporting server and is br-107fd915-b8c2-4cd3-aa50-891608f3965e.
=========================================
Hi
When I try to open a very big XLSX file with stock data (Cleaned for upload to bugzilla), it crashes and crash reporting server says: "Crash in: ScBroadcastAreaSlotMachine::StartListeningArea(ScRange const &,bool,SvtListener *)"
Then, it restarts and says that can restore files, but window is empty

Steps to reproduce:
1. Options - Advanced - Enable experimental features
2. Options - Calc - Defaults - Enable very large spreadsheets
3. Open attachment
4. Crash

I tried in LibreOffice 7.0 Beta 2 and RC1

Seems to be not the same as #134392
Comment 1 Xisco Faulí 2020-07-06 10:43:26 UTC
Reproduced in

Version: 7.1.0.0.alpha0+
Build ID: 9af38b4504ccda57a0c32eb8bdd03e5a8ca29ddc
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 2 Julien Nabet 2020-07-06 11:30:39 UTC
Created attachment 162702 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I got an assertion.
Comment 3 Felix Schwarz 2020-09-21 07:08:44 UTC
still reproducible with latest master (2020-09-20_14.51.16)

Version: 7.1.0.0.alpha0+
Build ID: 40f42f317757ef02d0a4d1cfd1c4f5bd8583e8e0
CPU threads: 12; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: de-DE (de_DE.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-09-20_14:51:16
Calc: threaded
Comment 4 kevinpr 2021-05-02 18:18:08 UTC
Tried in 


And got another different crash report
https://crashreport.libreoffice.org/stats/crash_details/f6aa4abf-c06c-41a6-a117-6f5403efa0a7
Comment 5 Julien Nabet 2021-05-03 19:10:44 UTC
Created attachment 171619 [details]
bt with debug symbols

Here's an updated bt with master sources updated today (still an assertion).
Comment 6 Roman Kuznetsov 2022-02-11 15:32:06 UTC
Today I can't repro it in

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 96e1be11540bada172fbdbfbbe3f9b7dc3e58462
CPU threads: 4; OS: Mac OS X 10.16; UI render: default; VCL: osx
Locale: ru-RU (ru_RU.UTF-8); UI: en-US
Calc: threaded Jumbo
Comment 7 Xisco Faulí 2022-02-14 10:02:14 UTC
Issue fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=8bb457d17ef970676f60976cc4e2de9c9f5340c0

Closing as duplicated of bug 109061

*** This bug has been marked as a duplicate of bug 109061 ***