Bug 134564 - Hierarchy of PS hard to follow sometimes
Summary: Hierarchy of PS hard to follow sometimes
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:7.1.0
Keywords:
Depends on:
Blocks: Styles_Inspector
  Show dependency treegraph
 
Reported: 2020-07-06 11:53 UTC by Heiko Tietze
Modified: 2020-07-27 10:07 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example with Test PS derived from Drawing (23.59 KB, image/png)
2020-07-06 11:53 UTC, Heiko Tietze
Details
Drawing style expanded by default (38.81 KB, image/png)
2020-07-08 13:21 UTC, pedro.silva
Details
SubDrawing example (37.75 KB, image/jpeg)
2020-07-08 13:47 UTC, pedro.silva
Details
Inspector Panel with TreeLines (32.85 KB, patch)
2020-07-10 19:23 UTC, Shivam Kumar Singh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Tietze 2020-07-06 11:53:53 UTC
Created attachment 162705 [details]
Example with Test PS derived from Drawing

If the PS has no changed attributes it will be listed empty. For example, add some formatted dummy text, focus citation, change to Drawing (underneath Citation) and derive some PS without changing any property. 

An option might be to force the expander triangle, if possible.
Comment 1 pedro.silva 2020-07-08 13:20:49 UTC
Interesting, when trying to replicate this using https://git.libreoffice.org/core/+log/b9d93fc47b2489764e251a11572fccef872df4e9 I get always the Drawing group expanded. Or am I missing something (?)

steps:

* insert text
* select paragraph 
* apply Paragraph Style: Caption
* apply any of its sub styles (that do not differ in terms of formatting)
  * apply figure
  * apply drawing
* both appear expanded

(see attachment)
Comment 2 pedro.silva 2020-07-08 13:21:26 UTC
Created attachment 162804 [details]
Drawing style expanded by default
Comment 3 pedro.silva 2020-07-08 13:47:08 UTC
Created attachment 162806 [details]
SubDrawing example
Comment 4 pedro.silva 2020-07-08 13:47:28 UTC
(In reply to pedro.silva from comment #3)
> Created attachment 162806 [details]
> SubDrawing example

oh so I missed the point. The problem is when we have multiple sublevel styles with equal attributes:

Steps:
* Create a new inherited style from Drawing e.g.: SubDrawing
* apply 
* now Drawing appears as a simple label without triangle and without visual relation to its child (in this case SubDrawing)
Comment 5 Shivam Kumar Singh 2020-07-10 19:23:32 UTC
Created attachment 162894 [details]
Inspector Panel with TreeLines

(In reply to Heiko Tietze from comment #0)

> An option might be to force the expander triangle, if possible.

That I think is not possible because in this case(and similar cases), no unique property gets redefined at Drawing hence the children of Drawing is empty.
If we do add an expander triangle, what will it show on clicking ?
The expander icon is a feature of .ui files and maybe there's no way to customise that manually.

A workthrough can be to show TreeLines as shown in the "Styles" panel as shown in the attachement.
Comment 6 Heiko Tietze 2020-07-11 08:38:32 UTC
(In reply to Shivam Kumar Singh from comment #5)
> A workthrough can be to show TreeLines as shown in the "Styles" panel...

Yes, that's a good solution (and easy to implement). I also like the coherence with the styles tree. And ultimately it might also benefit from implementing columns.
Comment 7 Commit Notification 2020-07-22 19:02:36 UTC
Shivam Kumar Singh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/19f44fe53863ef8c9087aa965b786544f71ffdc8

tdf#134564 tdf#134578 Improve hierarchy viewing in Inspector

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Shivam Kumar Singh 2020-07-23 14:22:38 UTC
(In reply to Heiko Tietze from comment #6)
> Yes, that's a good solution (and easy to implement). I also like the
> coherence with the styles tree. And ultimately it might also benefit from
> implementing columns.

Does it look good now ?
Changing it to Resolved