Bug 134595 - LO7RC1 PE: On macOS LO7PE crashes when creating a new document
Summary: LO7RC1 PE: On macOS LO7PE crashes when creating a new document
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.0.0.0.beta1+
Hardware: All Mac OS X (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: corruptProfile
Depends on:
Blocks:
 
Reported: 2020-07-07 06:05 UTC by Martin Srebotnjak
Modified: 2020-08-04 12:16 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
<spam> (2.57 KB, text/html)
2020-08-01 07:29 UTC, Reyy kakeru
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Srebotnjak 2020-07-07 06:05:19 UTC
Description:
Opening LO7RC1 (with sl-SI langpack) and then opening a new document (in Writer) LO crashes.
It reopens offering to repair the document and after repairing (and trying to open it) crashes again (and again).
Opening other documents doesn't crash it, but if another document is open while creating a new document, both documents are in the repair pipeline ...

Steps to Reproduce:
1. Open LibreOffice
2. Create/Open a new document
3.

Actual Results:
LO crashes.

Expected Results:
LO works.


Reproducible: Always


User Profile Reset: No



Additional Info:
Should I mention this is a bug in the "Personal Edition"?
The version list of Bugzilla should be updated with the vendor names of the listed builds.
Comment 1 Martin Srebotnjak 2020-07-07 06:06:44 UTC
As this bug makes LO useless on macOS, I am giving it highest importance.

Please change if bug cannot be confirmed on all of your macOS'.
Comment 2 Telesto 2020-07-07 06:47:29 UTC
Does this make a difference
Grant LibreOffice Full Disk Access in Security & Privacy -> Privacy in System preferences
Comment 3 Julien Nabet 2020-07-07 06:59:17 UTC
Could you give a try at https://wiki.documentfoundation.org/QA/FirstSteps ?

If you still reproduce this, would it be possible you retrieve more information? (see https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#macOS:_How_to_get_debug_information)
Comment 4 Martin Srebotnjak 2020-07-07 07:10:17 UTC
Yes, Telesto, there is a point there.
On the list of apps, granted Full Disk Access there is only one listed, "LibreOfficeDev", but I did not enter it manually.
I tried to add "LibreOffice", but even when it was closed, after selecting it from the apps list it did not appear on the list.
On opening a new document LO still crashes.
So obviously LO needs to be added to that list, but I cannot understand why macOS doesn't let me add it there, with admin privileges.
Comment 5 Martin Srebotnjak 2020-07-07 07:14:14 UTC
There must be some identification issue between LO and LODev (I have LO70b2 installed).
After I removed the confirmation in front of LODev in Full Disk Access and selected LO from the list of apps, LO was not added to the list, but LODev got selected again (with the tick).
Could it be that LORC1 is seen as LODev (and not as LO) by macOS?
Comment 6 Martin Srebotnjak 2020-07-07 07:16:44 UTC
Yes, I think this is the case.
I removed LODev from the list first and then added LibreOffice from the app list.
Item "LibreOfficeDev" was added and not "LibreOffice" to the full disk access list.
Comment 7 Julien Nabet 2020-07-07 07:26:10 UTC
Christian: thought you might be interested in this one.

Martin: it seems Telesto is right so no need to respond about my comment.
Comment 8 Martin Srebotnjak 2020-07-07 07:35:15 UTC
Julien, your comment - I cannot help that way. LO does not crash or freeze, only new document crashes upon creation, so there is no crash report (for Apple) generated.
Maybe there are some useful messages in the console available, but I do not know what to search for.
Comment 9 Julien Nabet 2020-07-07 07:40:10 UTC
(In reply to Martin Srebotnjak from comment #8)
> Julien, your comment - I cannot help that way. LO does not crash or freeze,
> only new document crashes upon creation, so there is no crash report (for
> Apple) generated.
Ok, no problem.

> Maybe there are some useful messages in the console available, but I do not
> know what to search for.

I don't know if there are a lot of console logs but perhaps you may copy all of them in a text file and attach the text file here?
Comment 10 Alex Thurgood 2020-07-07 11:02:51 UTC
I can't reproduce this with the default basic installation, but currently I can't install the FR langpack as it fails to recognize a valida LO7 installation (bug 134607).
Comment 11 Martin Srebotnjak 2020-07-07 11:16:40 UTC
Strange, I was able to install Slovenian langpack.

Also, LO70RC1 crashes when opening an existing odt file, but not an existing odg file.

So I tried creating new  documents in Calc, Impress, Draw, ..., and LO is fine with all except with new Writer documents, so this is a Writer-related bug?
Comment 12 Telesto 2020-07-07 11:46:13 UTC
I still assume the notarization stuff being broken. 

@Martin Srebotnjak 
Which version of Catalina - I assume - are you using? As bug 126409 ended up works for me..

Note; there was talk about including all language in the app bundle, supposing avoiding the issue, not sure how that's going..
Comment 13 Xisco Faulí 2020-07-09 13:43:28 UTC
(In reply to Telesto from comment #12)
> I still assume the notarization stuff being broken. 
> 
> @Martin Srebotnjak 
> Which version of Catalina - I assume - are you using? As bug 126409 ended up
> works for me..
> 
> Note; there was talk about including all language in the app bundle,
> supposing avoiding the issue, not sure how that's going..

Yes, it's important to know the macintosh version. In my case, I've just installed the french langpack on Mojave 10.14.6

Version: 7.0.0.1
Build ID: 04ba7e3f1e51af6c5d653e543a620e36719083fd
Threads CPU : 8; OS : Mac OS X 10.14.6; UI Render : par défaut; VCL: osx
Locale: en-US (en_ES.UTF-8); Langue IHM : fr-FR
Calc: threaded

and it doesn't crash. will try with slovenian.
BTW, have you tried with a clean profile ?
Comment 14 Xisco Faulí 2020-07-09 13:48:01 UTC
Everything fine with slovenian

Version: 7.0.0.1
Build ID: 04ba7e3f1e51af6c5d653e543a620e36719083fd
Niti CPE: 8; Op. sistem: Mac OS X 10.14.6; Upodobitev vmesnika: privzeta; VCL: osx
Locale: en-US (en_ES.UTF-8); jezik vmesnika: sl-SI
Calc: threaded

@Martin, a couple of things:
1. Try in safe mode
2. Mac version?

Putting to NEEDINFO
Comment 15 Martin Srebotnjak 2020-07-09 15:53:47 UTC
My macOS is 10.14.6.
Comment 16 QA Administrators 2020-07-10 03:48:22 UTC Comment hidden (obsolete)
Comment 17 Martin Srebotnjak 2020-07-16 08:28:15 UTC
It seems to work ok in safe mode.
Comment 18 Xisco Faulí 2020-07-16 13:13:17 UTC
(In reply to Martin Srebotnjak from comment #17)
> It seems to work ok in safe mode.

So, if you remove the profile folder, is it no longer reproducible ?
Comment 19 Martin Srebotnjak 2020-07-17 20:09:36 UTC
Yes.
Comment 20 QA Administrators 2020-07-18 03:40:56 UTC Comment hidden (obsolete)
Comment 21 Reyy kakeru 2020-08-01 07:29:49 UTC Comment hidden (spam)
Comment 22 Xisco Faulí 2020-08-04 12:16:23 UTC
(In reply to Martin Srebotnjak from comment #19)
> Yes.

Ok. Closing as a corrupted profile issue