Bug 134647 - CRASH: going to next slide on slideshow
Summary: CRASH: going to next slide on slideshow
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+ Master
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:7.1.0
Keywords: bibisected, bisected, regression
: 134575 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-07-08 10:42 UTC by Xisco Faulí
Modified: 2020-07-24 08:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample file (264.70 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2020-07-08 10:42 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-07-08 10:42:16 UTC
Created attachment 162791 [details]
sample file

Steps to reproduce:
1. Open attached document
2. F5
3. click on the screen or use any key to go to the next slide

-> Crash

Reproduced in

Version: 7.1.0.0.alpha0+
Build ID: 0695b5f5b328a1bc9cfdc8ba020dbdd674185e04
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-07-08 10:43:34 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=1cd0e02cdf7fc5b5903320ffd24865d11465d14b

author	Noel Grandin <noel.grandin@collabora.co.uk>	2020-07-06 09:48:01 +0200
committer	Noel Grandin <noel.grandin@collabora.co.uk>	2020-07-06 15:41:07 +0200
commit	1cd0e02cdf7fc5b5903320ffd24865d11465d14b (patch)
tree	f8d114a513b2fd4992c56637e9e3ba3d9d51863e
parent	ba556833e19b401496b5bf7304de574c64780f81 (diff)
cairo/canvas: create instances with uno constructors

Bisected with: bibisect-linux64-7.1

Adding Cc: to Noel Grandin
Comment 2 Xisco Faulí 2020-07-09 08:45:13 UTC
*** Bug 134575 has been marked as a duplicate of this bug. ***
Comment 3 Commit Notification 2020-07-11 06:57:13 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6dea1afe95aafe1a147e9b933b5cf89530f708b1

tdf#134647 crash going to next slide on slideshow

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Xisco Faulí 2020-07-13 09:56:26 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: 00be56d9db396d284f66ab723d6fbb898b888dfb
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Noel, thanks for fixing this issue!!