Bug 134655 - MacOS: Square characters in style dialog on CKB
Summary: MacOS: Square characters in style dialog on CKB
Status: RESOLVED DUPLICATE of bug 73494
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: x86-64 (AMD64) macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: MacOS-Wishlist
  Show dependency treegraph
 
Reported: 2020-07-08 14:13 UTC by jwtiyar
Modified: 2022-09-29 18:57 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Square text (37.96 KB, image/png)
2020-07-08 14:13 UTC, jwtiyar
Details
libreoffcie 7.1 (205.66 KB, image/png)
2021-02-10 04:52 UTC, jwtiyar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jwtiyar 2020-07-08 14:13:01 UTC
Created attachment 162807 [details]
Square text

Hey
I have installed ckb language pack, And some texts in the language shows up as square instead of normal kurdish text.
Comment 1 jwtiyar 2020-07-19 10:28:31 UTC
Installed RC2, And problem still exist.
Comment 2 Eyal Rozenberg 2020-07-25 16:00:44 UTC
What language did you download & use exactly?

https://www.libreoffice.org/download/download/?type=rpm-x86_64&version=6.4.5&lang=pick
Comment 3 jwtiyar 2020-07-25 16:31:51 UTC
(In reply to Eyal Rozenberg from comment #2)
> What language did you download & use exactly?
> 
> https://www.libreoffice.org/download/download/?type=rpm-x86_64&version=6.4.
> 5&lang=pick

It's mentioned in first message its CKB.
My language is not available yet in stable release.
Comment 4 jwtiyar 2020-08-01 09:47:31 UTC
Any progress? And LibreOffice will be released in a week?
Comment 5 Xisco Faulí 2020-08-04 12:16:52 UTC
Thank you for reporting the bug. To be certain the reported issue is not related to corruption in the user profile, could you please reset your Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the issue is still present
Comment 6 jwtiyar 2020-08-04 15:03:03 UTC
Thank you
But after resetting and going safe mode the language pack will be removed and goes back to english. The problem is with ckb .
Comment 7 QA Administrators 2020-08-05 04:56:26 UTC Comment hidden (obsolete)
Comment 8 Regina Henschel 2020-08-05 07:31:36 UTC
Do you have a font installed, that contains the glyphs? A search for 'kurdish font for mac free download' gives some results. But I cannot judge them.
Comment 9 jwtiyar 2020-08-06 14:05:09 UTC
(In reply to Regina Henschel from comment #8)
> Do you have a font installed, that contains the glyphs? A search for
> 'kurdish font for mac free download' gives some results. But I cannot judge
> them.

Hey 
Sorry for the late reply
Yes I have all fonts instaled inside system, But i don't think it's related to user fonts because the problem is not with typing, App itself not show them correctly.
Comment 10 Xisco Faulí 2021-02-09 15:20:42 UTC
Hello jwtiyar,
A new major release of LibreOffice is available since this bug was reported.
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 11 jwtiyar 2021-02-10 04:52:55 UTC
Created attachment 169642 [details]
libreoffcie 7.1
Comment 12 jwtiyar 2021-02-10 04:54:08 UTC
(In reply to Xisco Faulí from comment #10)
> Hello jwtiyar,
> A new major release of LibreOffice is available since this bug was reported.
> Could you please try to reproduce it with the latest version of LibreOffice
> from https://www.libreoffice.org/download/libreoffice-fresh/ ?
> I have set the bug's status to 'NEEDINFO'. Please change it back to
> 'UNCONFIRMED' if the bug is still present in the latest version.

Hey Xisco
Problem still exist.
Comment 13 QA Administrators 2021-02-11 04:12:08 UTC Comment hidden (obsolete)
Comment 14 eisa01 2022-02-05 14:37:20 UTC
I can confirm

The language pack is "Central Kurdish"

Version: 7.2.5.2 / LibreOffice Community
Build ID: 499f9727c189e6ef3471021d6132d4c694f357e5
CPU threads: 10; OS: Mac OS X 12.2; UI render: default; VCL: osx
Locale: en-US (en_US.UTF-8); UI: ckb-IQ
Calc: threaded
Comment 15 خالد حسني 2022-09-29 18:57:08 UTC

*** This bug has been marked as a duplicate of bug 73494 ***