Bug 134658 - Allow formatting odd or even table row
Summary: Allow formatting odd or even table row
Status: RESOLVED DUPLICATE of bug 105933
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.1 rc
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-08 14:37 UTC by maxloh.register
Modified: 2020-07-09 14:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Styled table that cannot be created with LibreOffice (1.70 KB, image/png)
2020-07-08 14:39 UTC, maxloh.register
Details

Note You need to log in before you can comment on or make changes to this bug.
Description maxloh.register 2020-07-08 14:37:41 UTC
Description:
Until now, there is now way to format odd or even table row in LibreOffice. It is impossible to create the table in the attached image.

The closest thing we get is "Autoformat Styles", but we can only use predefined styles but not creating our own.

Actual Results:
 

Expected Results:
 


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 maxloh.register 2020-07-08 14:39:09 UTC
Created attachment 162809 [details]
Styled table that cannot be created with LibreOffice
Comment 2 maxloh.register 2020-07-08 14:42:08 UTC
https://design.blog.documentfoundation.org/2015/12/13/style-your-tables/

There was a UI design proposed for solving this issue but never being implemented.
Comment 3 Maxim Monastirsky 2020-07-08 15:14:58 UTC
(In reply to maxloh.register from comment #0)
> The closest thing we get is "Autoformat Styles", but we can only use
> predefined styles but not creating our own.
This isn't accurate. While there is indeed no UI for editing table styles, you can create a sample 4x4 table, format it like you want, select all its cells, and then use the "New style from selection" action from the styles sidebar panel to create a style based on the given design.

Anyway, as you're mostly asking for a UI, I think this is a duplicate of Bug 105933 which tracks this problem.

*** This bug has been marked as a duplicate of bug 105933 ***
Comment 4 maxloh.register 2020-07-08 18:37:39 UTC
(In reply to Maxim Monastirsky from comment #3)
> This isn't accurate. While there is indeed no UI for editing table styles,
> you can create a sample 4x4 table, format it like you want, select all its
> cells, and then use the "New style from selection" action from the styles
> sidebar panel to create a style based on the given design.

I think this is not a duplicate feature request. The main point is about applying style to only odd or even rows. This feature cannot be implemented by solving bug 105933.
Comment 5 Maxim Monastirsky 2020-07-08 19:17:23 UTC
(In reply to maxloh.register from comment #4)
> I think this is not a duplicate feature request.
How is that? In comment 2 you said that the UI changes outlined in the blog post should solve the problem. And Bug 105933 is where the implementation of this UI is tracked.

> The main point is about applying style to only odd or even rows.
Of course. It's a feature of a table style ("AutoFormat") that you can define different formatting for odd and even rows. Did you actually try to follow the steps I gave? If the sample table has different formatting for odd and even rows, then any table that has the resulting style applied, will have this too. And it will kept consistent when adding/removing rows. Otherwise I just don't understand what you mean.

(And by the way, please don't change your own bugs to NEW. Someone else needs to confirm them first.)
Comment 6 maxloh.register 2020-07-09 14:02:18 UTC
(In reply to Maxim Monastirsky from comment #5)
> (In reply to maxloh.register from comment #4)
> > I think this is not a duplicate feature request.
> How is that? In comment 2 you said that the UI changes outlined in the blog
> post should solve the problem. And Bug 105933 is where the implementation of
> this UI is tracked.
> 
> > The main point is about applying style to only odd or even rows.
> Of course. It's a feature of a table style ("AutoFormat") that you can
> define different formatting for odd and even rows. Did you actually try to
> follow the steps I gave? If the sample table has different formatting for
> odd and even rows, then any table that has the resulting style applied, will
> have this too. And it will kept consistent when adding/removing rows.
> Otherwise I just don't understand what you mean.
> 
> (And by the way, please don't change your own bugs to NEW. Someone else
> needs to confirm them first.)

OK. This bug should be a duplicate then.

*** This bug has been marked as a duplicate of bug 105933 ***