Bug 134722 - Permit configuration of which external image editor is used
Summary: Permit configuration of which external image editor is used
Status: RESOLVED DUPLICATE of bug 51096
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-10 18:22 UTC by Calum McConnell
Modified: 2020-07-10 19:11 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Calum McConnell 2020-07-10 18:22:29 UTC
Description:
Libreoffice provides a shortcut to its users that lets them chose to edit an image in an external tool.  However, using it only refers the user to the operating system's default tool for opening image files.  In many cases, that tool is not a good one for editing image files.

For instance, I have set GNOME to open image files with its viewer, so that if I download an image, I can easily view it without waiting for GIMP to load.  However, that means that if I select "edit in external tool", I don't get a usable image editor.

This would be solved by permitting the user to specify some other image editor to use: perhaps as a path in that section of options, or even just an expert configuration variable.  If such a variable exists, it is currently completly undocumented.

Steps to Reproduce:
1. Set your operating system's tool for opening image files to be some sort of image viewer
2. Open a libreoffice document containing an image
3. Hit "Format -> Edit in external tool"

Actual Results:
The image is opened in the image viewer, which may be totally incapable of editing

Expected Results:
The image is opened in a user-specified tool, which is capable of editing


Reproducible: Always


User Profile Reset: No



Additional Info:
The documentation around images and their menus is not clear and is in need of an update
Comment 1 Roman Kuznetsov 2020-07-10 19:11:07 UTC

*** This bug has been marked as a duplicate of bug 51096 ***