Bug 134733 - Fonts preview illegible with Breeze Dark theme
Summary: Fonts preview illegible with Breeze Dark theme
Status: RESOLVED DUPLICATE of bug 135565
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.0.0.0.beta1+
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-11 17:07 UTC by Víctor Lara
Modified: 2020-09-18 16:48 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A screenshot of the issue (41.91 KB, image/png)
2020-09-17 12:31 UTC, calvin.f.hoy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Víctor Lara 2020-07-11 17:07:48 UTC
Description:
I have Libreoffice 7.0 (Opensuse Tumbleweed). When I use the Breeze theme, Writer shows the fonts preview without problems (in the drop-down menu, white background and black fonts). But when I use the dark theme, the drop-down menu fails and looks almost illegible.

Steps to Reproduce:
1. Apply Breeze dark theme (Opensuse Tumbleweed)
2. Check fonts preview (in Writer)
3. Drop-down fonts menu looks illegible (-very- light grey fonts with white background).
4. The normal Breeze theme (light) works with any problems (in Writer).

Actual Results:
When I apply de dark Breeze theme the drop-down fonts menu fails: white fonts (in fact, light grey) with white background. When I disable de fonts preview the drop-down menu looks normal (black background with white fonts, obviously without preview).

Expected Results:
The drop-down fonts menu (in dark mode, with fonts preview checked in Writer) should be legible, (dark background with white fonts).


Reproducible: Always


User Profile Reset: Yes



Additional Info:
The fonts size menu or paragraph works properly with dark theme. The problem is only in the fonts menu with preview activated.
Comment 1 Timur 2020-07-12 15:13:25 UTC Comment hidden (obsolete)
Comment 2 Mihkel Tõnnov 2020-07-13 05:18:55 UTC
This doesn't look like a dupe of bug 127138...
Comment 3 calvin.f.hoy 2020-09-17 12:31:47 UTC
Created attachment 165622 [details]
A screenshot of the issue

Happens to me as well. Arch Linux, KDE Plasma 5.19.5, using Breeze Dark Theme.
Comment 4 calvin.f.hoy 2020-09-17 12:35:20 UTC
Moving this to UI because it happens not just in Writer, but also in Calc, Impress and Draw.
Comment 5 Timur 2020-09-17 13:43:36 UTC
New per Comment 3. Please test with master, from https://dev-builds.libreoffice.org/daily/master/current.html or Appimage from https://libreoffice.soluzioniopen.com/daily-version/.
Comment 6 Ming Hua 2020-09-17 14:42:06 UTC
Could be a duplicate of, or at least related to, bug 135565.
Comment 7 Buovjaga 2020-09-18 06:49:12 UTC
Thanks Timur and Ming. I think the evidence is so strong that we should put this to NEEDINFO.
Comment 8 calvin.f.hoy 2020-09-18 16:48:02 UTC
While this bug was reported earlier, technically making bug 135565 a duplicate of this bug, I'll mark this one as duplicate since the issue was (mostly) resolved there. Thanks Timur and Ming.

*** This bug has been marked as a duplicate of bug 135565 ***