Bug 134739 - IMPRESS: two Align submenus under Format menu (one for text, other for objects/shapes)
Summary: IMPRESS: two Align submenus under Format menu (one for text, other for object...
Status: RESOLVED DUPLICATE of bug 138203
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: difficultyBeginner, easyHack, skillDesign, topicUI
Depends on:
Blocks: Main-Menu
  Show dependency treegraph
 
Reported: 2020-07-11 22:25 UTC by Mihkel Tõnnov
Modified: 2020-11-19 13:46 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Under Format, there are two submenus named Align (50.91 KB, image/png)
2020-07-11 22:25 UTC, Mihkel Tõnnov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mihkel Tõnnov 2020-07-11 22:25:37 UTC
Created attachment 162913 [details]
Under Format, there are two submenus named Align

There are two Align submenus under Format menu in Impress (see screenshot).
One contains commands for text alignment, other for object/shape/image alignment.
Turns out it has been like this since 5.1.

The first Align submenu (the one for text alignment; currently key-ID VShLc) is shared with Writer, Calc and Draw.

The second Align submenu (key-ID wgQ27) is shared with Draw, but located under the Shape menu there.
Comment 1 Maxim Monastirsky 2020-07-12 07:36:44 UTC
(In reply to Mihkel Tõnnov from comment #0)
> The first Align submenu (the one for text alignment; currently key-ID VShLc)
> is shared with Writer, Calc and Draw.
Not really. The submenu in Draw and Impress contains commands like .uno:LeftPara and .uno:RightPara which are text specific, while in Writer and Calc it has commands like .uno:CommonAlignLeft and .uno:CommonAlignRight that work with both text and shapes alignment.

A solution might be to implement those .uno:Common* commands for Impress, and use them in the menu instead of the text and shapes specific ones. A downside of this is that it will no longer be possible to set text alignment while a shape isn't in a text edit mode, as those commands will align the shape itself, and not its text (this isn't a problem in Writer, as there it isn't possible to format a shape text unless it's in an edit mode). But that might be a good tradeoff. Another headache is that the new commands won't show the keyboard shortcuts that assigned to the text specific commands (see also Bug 101951). And a solution like in Bug 95854 won't work here, as the text and the common commands will do different things.

Another solution might be to move the shapes related menu item out of the Format menu, into a dedicated shapes menu, like it was done in Draw.

A third possible solution is to rename that submenu to "Text Align" or something like this (while making sure this renaming does not affect other modules that use the same command).
Comment 2 DarkTrick 2020-07-16 13:52:30 UTC
Short: Perhaps I'd support moving the menu item.


Broaden the subject
===================
I would argue, that the content of the "Format" menu  does not make sense in some cases. 

For me personally "Format" is something intrinsic and persistent.  So it's strange, that "aligning objects" is under "Format" in the first place. In contrast: "Arranging" object (z-axis) is more temporary; "Convert"ing an object is a one-time action. (... and I'm not even sure what "Rotate" is intended for...)

Back to the main topic
======================
Compare the menu structure to the tabbed user-interface: 
 - Text alignment is under "Home" 
 - Object alignment is under "Layout"
At first glance this makes perfect sense
  
My thoughts
============
  Maybe "Align", "Arrange" and "Group" might be better off in Edit? Maybe with a(n unselectable) header row on top? 
  
  Maybe even a dedicated Menu item "Object" might make sense. Semantically Object->Group, Object->align, Object->arrange, Object->convert make pretty good sense to me. (Maybe there's a better term than "Object")
  
  
About the idea of renaming
==========================
Most simple solution. But it would try to work around the fact, that the menu items should not be under "Format". (IMO)
Comment 3 Heiko Tietze 2020-07-17 09:58:47 UTC
We discussed the topic in the design meeting. The special shapes menu would be an overkill for Impress and the combined UNO command has too many drawbacks. So two solutions are possible: 

* rename Alignment to "Object Alignment" (keep <text> alignment)
* move (object) Alignment into the Arrange submenu

Code pointer
./sd/uiconfig/simpress/menubar/menubar.xml
<menu:menu menu:id=".uno:ObjectAlign">
Comment 4 Heiko Tietze 2020-07-17 10:00:24 UTC
(In reply to DarkTrick from comment #2)
>   Maybe "Align", "Arrange" and "Group" might be better off in Edit?

I don't edit the alignment, I set it.

> About the idea of renaming ... Most simple solution. 

Plus, we don't fiddle around with the menu structure. Users hate this.
Comment 5 Mihkel Tõnnov 2020-07-17 10:09:19 UTC
(In reply to Heiko Tietze from comment #3)
> We discussed the topic in the design meeting. The special shapes menu would
> be an overkill for Impress and the combined UNO command has too many
> drawbacks. So two solutions are possible: 
> 
> * rename Alignment to "Object Alignment" (keep <text> alignment)

(In reply to Heiko Tietze from comment #4)
> (In reply to DarkTrick from comment #2)
> > About the idea of renaming ... Most simple solution. 
> 
> Plus, we don't fiddle around with the menu structure. Users hate this.

+1 for renaming.

(In the Estonian translation, I actually did this already a long time ago, so there's equivalent of "Text alignment" in Writer/Calc/Impress/Draw and "Object alignment" in Impress/Draw. Not sure why I didn't file a bug back then, though - probably assumed it will get noticed&changed soon enough anyway and then forgot all about it.)
Comment 6 Mihkel Tõnnov 2020-11-19 13:46:58 UTC

*** This bug has been marked as a duplicate of bug 138203 ***