Bug 134778 - PAGE HEADER: Size of table doesn't respect size of page header
Summary: PAGE HEADER: Size of table doesn't respect size of page header
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.1 rc
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Header-Footer Cell-Management
  Show dependency treegraph
 
Reported: 2020-07-13 11:48 UTC by Mike Silbermann
Modified: 2020-07-22 12:20 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
template working correct in LO 6.4.5. and early (258.22 KB, application/vnd.oasis.opendocument.text-template)
2020-07-13 11:50 UTC, Mike Silbermann
Details
Comparison LibreOffice 6.4 (left) VS LibreOffice 7.1 master (right) (197.46 KB, image/png)
2020-07-16 08:58 UTC, Xisco Faulí
Details
Without error (28.86 KB, image/jpeg)
2020-07-17 06:50 UTC, Mike Silbermann
Details
Error Table in 7.0.0 (28.99 KB, image/jpeg)
2020-07-17 06:51 UTC, Mike Silbermann
Details
Without error (28.86 KB, image/jpeg)
2020-07-17 06:51 UTC, Mike Silbermann
Details
Template to test it (258.22 KB, application/vnd.oasis.opendocument.text-template)
2020-07-17 06:52 UTC, Mike Silbermann
Details
Without error in LO 6.4.5 (34.42 KB, image/jpeg)
2020-07-17 08:14 UTC, Mike Silbermann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Silbermann 2020-07-13 11:48:38 UTC
Description:
The Format Table in LO Writer 7.0.0.1 dont wokt the template from Version 6.4.5.
A Table dont show the corret distance to next .... In Version it is correct.

Steps to Reproduce:
1.open the sendet tample in a new document
2. fields in table are to big to the next field
3.

Actual Results:
fields from table are to big to next line... distance dant reduce... can onli reduce format of script

Expected Results:
open die Field correct 


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: de
Module: TextDocument
[Information guessed from browser]
OS: Windows 10
OS is 64bit: yes
Comment 1 Mike Silbermann 2020-07-13 11:50:01 UTC
Created attachment 162964 [details]
template working correct in LO 6.4.5. and early

Version LO 7.0.0.1 fields from table are to big.
Comment 2 Xisco Faulí 2020-07-16 08:58:48 UTC
Created attachment 163100 [details]
Comparison LibreOffice 6.4 (left) VS LibreOffice 7.1 master (right)
Comment 3 Xisco Faulí 2020-07-16 08:59:15 UTC
I can't reproduce it in

Version: 7.1.0.0.alpha0+
Build ID: d851a02df57ab378ed0cc6d9362516de09c3279c
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

Please, attach a screenshot showing how it looks for you
Comment 4 Mike Silbermann 2020-07-17 06:50:42 UTC
Created attachment 163152 [details]
Without error

Thats correct
Comment 5 Mike Silbermann 2020-07-17 06:51:11 UTC
Created attachment 163153 [details]
Error Table in 7.0.0
Comment 6 Mike Silbermann 2020-07-17 06:51:41 UTC
Created attachment 163154 [details]
Without error
Comment 7 Mike Silbermann 2020-07-17 06:52:19 UTC
Created attachment 163155 [details]
Template to test it
Comment 8 Mike Silbermann 2020-07-17 08:14:42 UTC
Created attachment 163156 [details]
Without error in LO 6.4.5
Comment 9 QA Administrators 2020-07-18 03:41:04 UTC Comment hidden (obsolete)
Comment 10 Dieter 2020-07-22 07:37:56 UTC
I confirm the behaviour: Row height of the table changed from 6.4 to 7.0.
Line Space is in both cases 1,5; setting of row height is "Fit to size"

So for me the question is, if Fit to size should respect height of page header (as it does in LO 6.4 or line space (as it does in 7.0)

I would expect, that table size respects height of page header, so I would treat it as a bug.

cc: Design-Team for (alternative) opinions

Version: 7.0.0.0.beta2 (x64)
Build ID: 1c213561a365b5666167321de68c9977500c9612
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL
Comment 11 Mike Silbermann 2020-07-22 09:33:25 UTC
Yes... I belive it is a error.
In Version 7.0.0.2 works it.
Comment 12 Dieter 2020-07-22 11:12:08 UTC
(In reply to Mike Silbermann from comment #11)
> In Version 7.0.0.2 works it.

Very good. So lets close as WORKSFORME.
Comment 13 Heiko Tietze 2020-07-22 11:48:53 UTC
The use case is weak, placing a table in the page header is bad design, and I'm having a hard time to reproduce the issue with the complex layout. Dieter, can you make a minimum non-viable example?

In general, we have "Autofit height" for the page header as well as "Fit to size" for row height. So everything should be possible.

Set to WFM meanwhile, perfect.
Comment 14 Dieter 2020-07-22 11:53:29 UTC
(In reply to Heiko Tietze from comment #13)
> Dieter, can you make a minimum non-viable example?

Sorry Heiko, what do you mean with "non-viable example"?
Comment 15 Heiko Tietze 2020-07-22 12:20:39 UTC
(In reply to Dieter from comment #14)
> (In reply to Heiko Tietze from comment #13)
> > Dieter, can you make a minimum non-viable example?
> 
> Sorry Heiko, what do you mean with "non-viable example"?

The opposite of minimum viable product, something that is just as little broken as possible. Silly joke, admitted. WFM is perfectly fine for me.