Bug 134788 - Inserting a table with 4000-6000 takes a long time to process since 5.1
Summary: Inserting a table with 4000-6000 takes a long time to process since 5.1
Status: NEEDINFO
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2020-07-13 20:52 UTC by Telesto
Modified: 2020-07-16 10:45 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-07-13 20:52:49 UTC
Description:
Inserting a table with 4000-6000 rows slower since 5.1. Motivation/reason for trying: bug 134779 

Steps to Reproduce:
1. Open Writer
2. Insert -Table -> Type 5000 rows

Actual Results:
Inserting is really slow (how big the number how slower it gets)

Expected Results:
As fast as in 5.0


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: c48e4d795e37f23b71d647247590807ab9e52223
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

and in
5.2

but not in
5.0
Comment 1 Xisco Faulí 2020-07-16 10:45:12 UTC
I can't reproduce it in

Version: 7.1.0.0.alpha0+
Build ID: d851a02df57ab378ed0cc6d9362516de09c3279c
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

I can type, scroll, do whatever I want while the table is being inserted, same behaviour as with LibreOffice 4.4. In fact, it seems slower in LibreOffice 4.4 than in master for me.
Please, add a screencast of both versions to see the differences