Download it now!
Bug 134808 - Image not rendered since 7.0 (empty rectangle)
Summary: Image not rendered since 7.0 (empty rectangle)
Status: RESOLVED DUPLICATE of bug 134841
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Regressions-cairo-speedup
  Show dependency treegraph
 
Reported: 2020-07-14 20:05 UTC by Telesto
Modified: 2020-07-16 11:20 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Bibisect log (3.52 KB, text/plain)
2020-07-14 20:06 UTC, Telesto
Details
Example file (1.80 MB, application/vnd.oasis.opendocument.text)
2020-07-14 20:16 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-07-14 20:05:48 UTC
Description:
Image not rendered since 7.0 (empty rectangle)

Steps to Reproduce:
1. Open the attached file
2. Right bottom (below Ali Fethi Okyar) is an image.. it will be 'visible'when dragging)

Actual Results:
Image invisible

Expected Results:
Visible as before


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: c48e4d795e37f23b71d647247590807ab9e52223
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-07-14 20:06:44 UTC
Created attachment 163027 [details]
Bibisect log

Bisected to:

author	Armin Le Grand (Collabora) <armin.le.grand@me.com>	2020-02-21 16:58:17 +0100
committer	Armin Le Grand <Armin.Le.Grand@me.com>	2020-02-21 20:16:59 +0100
commit	828504974d70111e4a35b31d579cf42fe660a660 (patch)
tree	4c2f7720b3efaecf55b8fa7b9b3eeccb278160e6
parent	813cde918338bccc4f711230616340cad2c1d4a0 (diff)
tdf#130768 speedup huge pixel graphics Cairo
For more information/documentation please
refer to the bugzilla task

Fixed a crash in CppunitTest_desktop_lib which
led to a missing test of mpGraphics in
OutputDevice::DrawTransformedBitmapEx. Other
public methods test that and one of the goals
of the cange was to use that method more often,
so this may have never been detected before

https://cgit.freedesktop.org/libreoffice/core/commit/?id=828504974d70111e4a35b31d579cf42fe660a660
Comment 2 Telesto 2020-07-14 20:16:39 UTC
Created attachment 163028 [details]
Example file
Comment 3 Xisco Faulí 2020-07-16 11:20:12 UTC
fixed by https://gerrit.libreoffice.org/c/core/+/98892

*** This bug has been marked as a duplicate of bug 134841 ***