Download it now!
Bug 134813 - Writer created PDF Forms dont work properly
Summary: Writer created PDF Forms dont work properly
Status: RESOLVED DUPLICATE of bug 127217
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: possibleRegression
Depends on:
Blocks: Form-Controls
  Show dependency treegraph
 
Reported: 2020-07-14 22:02 UTC by tobyps
Modified: 2020-09-19 15:39 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
odt of the form (26.76 KB, application/vnd.oasis.opendocument.text)
2020-07-14 22:21 UTC, tobyps
Details
Working version of form with 6.2 (75.98 KB, application/pdf)
2020-07-14 22:24 UTC, tobyps
Details
broken version 6.4 (78.82 KB, application/pdf)
2020-07-14 22:24 UTC, tobyps
Details
broken version 7.0rc (78.35 KB, application/pdf)
2020-07-14 22:24 UTC, tobyps
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tobyps 2020-07-14 22:02:58 UTC
Description:
Creating a Form with Writer, the Textboxes and Options on the first of two pages work fine. 
On the Second page the Options are not working (dont take any input).

A textbox for a Date ist duplicated in the form for a total of 4, 2 on the first page (work fine), two on the second which dont work, its impossible to enter text and they dont copy the text of the duplicate boxes.
A duplicate Textbox, 1 on first page, 1 on second page, works fine

This behaviour is showing up since Version 6.3, 6.4 and 7.0 RC have the same problem. 
Creating the form with 6.2 works fine.

I tested a document from scratch with 7.0 RC1 and though nothing was copied it showed the same behaviour, first page, all boxes and options work fine, second page is broken



Steps to Reproduce:
1.Create a form with multiple Textboxes and Options.
2.Duplicate some of the Textboxes on the second page of the form
3.Create PDF form with duplicates

Actual Results:
Some of the Textboxes and Options on the Second Page wont work

I could reproduce it with different PCs and different Versions of  LO 

Expected Results:
A working form.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
The form doesnt contain personal data, so I could provide a copy for others to test.
Comment 1 tobyps 2020-07-14 22:21:54 UTC
Created attachment 163032 [details]
odt of the form
Comment 2 tobyps 2020-07-14 22:24:16 UTC
Created attachment 163033 [details]
Working version of form with 6.2
Comment 3 tobyps 2020-07-14 22:24:38 UTC
Created attachment 163034 [details]
broken version 6.4
Comment 4 tobyps 2020-07-14 22:24:59 UTC
Created attachment 163035 [details]
broken version 7.0rc
Comment 5 Telesto 2020-07-15 07:33:21 UTC
Is this specific for certain PDF reader? I'm not having issues with the 'broken' forms
Comment 6 tobyps 2020-07-15 08:05:53 UTC
Good point, I hadnt checked because Firefox cant handle forms and I asumed only dedicated pdf readers handle them (and I have only Acrobat installed).

It doesnt work in the current version auf Adobe Acrobat Reader DC (20.009.20074)

It works in the chrome based version of Edge (not in the former Version) and it works in Chrome.

I would still consider it a bug, but it could be a bug in Acrobat Reader.
Comment 7 Dieter 2020-07-20 15:26:22 UTC
Tested with

Version: 7.0.0.0.beta2 (x64)
Build ID: 1c213561a365b5666167321de68c9977500c9612
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

and

Version: 6.4.4.2 (x64)
Build-ID: 3d775be2011f3886db32dfd395a6a6d1ca2630ff
CPU-Threads: 4; BS: Windows 10.0 Build 19041; UI-Render: GL; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded

Option Button can't be selected in PDF (I also used Adobe Acrobat Reader DC 20.009.20074)

=> NEW
Comment 8 raal 2020-08-14 14:43:12 UTC
works for me with Version: 7.1.0.0.alpha0+ (x64)
Build ID: 1db7decf3fb172542f5fce03ce7bf0cb310d1ffc
CPU threads: 4; OS: Windows 10.0 Build 17763; UI render: Skia/Raster; VCL: win
and Acrobat 2019.021.20061

Attached broken PDF doesn't work in my version of Acrobat, so it looks fixed in dev version. Please can you test it?
http://dev-builds.libreoffice.org/daily/
Thank you
Comment 9 tobyps 2020-08-14 18:54:31 UTC
raal, thx for your test.

As your Adobe Reader is an older version, I wasnt able to test it.

But with the current version 2020.012.20041 and LibreOffice 7.1alpha (August 14th) I still had the same Problem. 

Could you test one of the attached "broken" pdfs with your Reader Version and/or test if the pdf you created with LibreOffice works for you with the current version of Adobe Reader?

Thx
Comment 10 Dieter 2020-09-02 06:14:45 UTC
Option button still doesn't work with

Version: 7.0.1.2 (x64)
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: threaded

I've tested with option button from the document and with new option buttons.
Comment 11 Dieter 2020-09-18 11:29:05 UTC
*** Bug 136849 has been marked as a duplicate of this bug. ***
Comment 12 Dirk Munk 2020-09-18 12:55:00 UTC
I did some testing with the pdf file I uploaded with Bug 136849 .

Adobe Acrobat Reader: text fields work fine, radio buttons do not work.
Google Chrome: seems to be a read-only viewer, nothing works.
Microsoft Edge: text fields and radio buttons work.
Comment 13 Dieter 2020-09-18 12:58:27 UTC
(In reply to Dirk Munk from comment #12)
> Adobe Acrobat Reader: text fields work fine, radio buttons do not work.

Which version do you use? I use 2020.012.20043
Comment 14 Dieter 2020-09-18 12:59:53 UTC
(In reply to raal from comment #8)
> works for me with Version: 7.1.0.0.alpha0+ (x64)
> and Acrobat 2019.021.20061

Can you test with actual version of Adobe Acrobat Reader?
Comment 15 Dirk Munk 2020-09-18 13:18:59 UTC
(In reply to Dieter from comment #13)

I am using LibreOffice 7.0.0.3 (x64) and Adobe Acrobat Reader DC 2020.012.2043 .
Comment 16 Oliver Brinzing 2020-09-19 14:55:38 UTC
maybe related to/a duplicate of:

Bug 127217 - PDF export: LibreOffice 6.3 option buttons in forms not working in Adobe Reader (OK in other readers)

?
Comment 17 Timur 2020-09-19 15:39:47 UTC

*** This bug has been marked as a duplicate of bug 127217 ***