Download it now!
Bug 134820 - Crash after undo with experimental features enabled
Summary: Crash after undo with experimental features enabled
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.1.0
Keywords: haveBacktrace
Depends on:
Blocks: Styles_Inspector
  Show dependency treegraph
 
Reported: 2020-07-15 08:17 UTC by Telesto
Modified: 2020-07-30 09:18 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (27.56 KB, application/vnd.oasis.opendocument.text)
2020-07-15 08:17 UTC, Telesto
Details
Screencast (2.37 MB, video/mp4)
2020-07-15 20:44 UTC, Telesto
Details
backtrace on Linux (9.89 KB, text/plain)
2020-07-20 17:38 UTC, Terrence Enger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-07-15 08:17:09 UTC
Description:
Crash after undo with experimental features enabled

Steps to Reproduce:
1. Open the attached file
2. Click somewhere on the first page
3. Insert a chart
4. Undo -> Crash

Actual Results:
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: d851a02df57ab378ed0cc6d9362516de09c3279c
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-07-15 08:17:20 UTC
Created attachment 163043 [details]
Example file
Comment 2 Xisco Faulí 2020-07-15 19:01:28 UTC
I can't reproduce it in

Version: 7.1.0.0.alpha0+
Build ID: d851a02df57ab378ed0cc6d9362516de09c3279c
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

I believe you use ESC or click somewhere in the document before undoing the chart insertion
Comment 3 Telesto 2020-07-15 20:44:00 UTC
Created attachment 163079 [details]
Screencast

Was confused myself a bit, Style Inspector tab should be visible
Comment 4 Terrence Enger 2020-07-20 17:38:53 UTC
Created attachment 163332 [details]
backtrace on Linux

The backtrace is from commit 0d45380c (2020-07-17) built and running
on debian-buster.

Terminal messages include

    warn:chart2.tools:17729:17729:chart2/source/tools/WrappedPropertySet.cxx:137: found no inner property set to map to
    warn:chart2:17729:17729:chart2/source/tools/LifeTime.cxx:117: This component is already disposed 
    Application Error

I am adding keyword haveBacktrace.
Comment 5 Terrence Enger 2020-07-20 19:00:31 UTC
The code leading up to
svx/source/sidebar/inspector/InspectorTextPanel.cxx line 63 reads

61: void InspectorTextPanel::updateEntries(const std::vector<TreeNode>& rStore)
62: {
63:     mpListBoxStyles->freeze();

This function is frame #14 in the previously attached backtrace.

In the second call to this function,
    mpListBoxStyles = std::unique_ptr<weld::TreeView> 
                    = {get() = 0x9999999999999999}
and the call to freeze() results in an immediate segfault.
Comment 6 Terrence Enger 2020-07-21 14:46:00 UTC
I am adding Shivam Kumar Singh to cc.  I think the Styles Inspector is
your area, is it not?
Comment 7 Shivam Kumar Singh 2020-07-23 14:01:50 UTC
(In reply to Terrence Enger from comment #6)
> I am adding Shivam Kumar Singh to cc.  I think the Styles Inspector is
> your area, is it not?

Yes, Thank You.
I confirm this with :-

Version: 7.1.0.0.alpha0+
Build ID: 6e89b8aa81af8197cf9c826792e99938d582ae14
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: en-IN (en_IN); UI: en-US
Calc: threaded
Comment 8 Mike Kaganski 2020-07-27 10:59:13 UTC
Likely the same problem as in tdf#135179. Inserting a chart changes the component temporarily; that likely re-creates all panels of sidebar, invalidating previously set link.
Comment 9 Commit Notification 2020-07-28 19:20:07 UTC
Shivam Kumar Singh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/3b8c893b487a3ee27bac710da74856225fb72950

tdf#135178 tdf#135179 tdf#134820 Issue in SetChgLnk in Inspector

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Xisco Faulí 2020-07-30 09:18:52 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: 231e1e416c039d1f9724962a89cf0573a3db48a2
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Shivam Kumar Singh, thanks for fixing this issue!!