Bug 134824 - FILEOPEN DOCX : The position and format of footnotes are not displayed correctly
Summary: FILEOPEN DOCX : The position and format of footnotes are not displayed correctly
Status: RESOLVED DUPLICATE of bug 58521
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-15 08:53 UTC by NSO LibreOffice Team
Modified: 2020-12-02 12:37 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (14.22 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-07-15 08:53 UTC, NSO LibreOffice Team
Details
Comparison MSO 2010 and LibreOffice 7.1 master (126.83 KB, image/png)
2020-07-15 18:57 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NSO LibreOffice Team 2020-07-15 08:53:59 UTC
Created attachment 163048 [details]
Example file

Description:
Create a new word file, insert footnotes in the text, and then save it as docx to close the document. Open with lo and find the footnotes on the next page 


Steps to Reproduce:
1.Create a new word document, insert footnotes in the text
2.save it as docx, and then close the document
3.Open with lo and find the footnotes on the next page


Actual Results:
Open with Lo, find the footnotes on the next page

Expected Results:
Open with Lo, footnotes should appear on the current page

Reproducible: 
Always

Additional Info:
Version Infomation
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 4c14c88cc681abab787a461a1bea502a777f37e6
CPU threads: 12; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: zh-CN (zh_CN); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-07-15 18:57:57 UTC
Created attachment 163075 [details]
Comparison MSO 2010 and LibreOffice 7.1 master
Comment 2 Xisco Faulí 2020-07-15 18:58:11 UTC
Reproduced in

Version: 7.1.0.0.alpha0+
Build ID: d851a02df57ab378ed0cc6d9362516de09c3279c
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 3 Xisco Faulí 2020-07-15 18:59:22 UTC
Also reproduced in

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 4 NISZ LibreOffice Team 2020-12-02 12:37:47 UTC
This document contains endnotes. These are placed on a new page after the last one  in non-doc formats.

*** This bug has been marked as a duplicate of bug 58521 ***