Bug 134833 - Newly introduced additions feature needs a dedicated icon
Summary: Newly introduced additions feature needs a dedicated icon
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+ Master
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: target:7.1.0
Keywords:
Depends on:
Blocks: Icon-Request Extension-Tight-Integration
  Show dependency treegraph
 
Reported: 2020-07-15 12:50 UTC by Yusuf Keten
Modified: 2020-07-20 08:50 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yusuf Keten 2020-07-15 12:50:09 UTC
Description:
An icon is required for the UNO command ".uno:AdditionsDialog".

Actual Results:
There is no icon.

Expected Results:
An icon should exist.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+
Build ID: f29ff351424c38e343948ecb322b723a984ef907
CPU threads: 12; OS: Linux 5.3; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: CL
Comment 1 Heiko Tietze 2020-07-15 15:12:04 UTC
It's not an ordinary UNO command and will never be shown on the menu or toolbar since the dialog always opens with a context. For example, to load dictionary extension or gallery items etc. It should be started per button directly at the control, to pick the dictionaries Tools > Options > Language > Writing Aids - instead of "Get more dictionaries". This button should be recognizable across the application as a way to get more content and in most cases it will be an icon-only button.
Comment 2 Commit Notification 2020-07-16 03:08:52 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/39ec20cd90164089cb2b9a89e1b7d64a1c12822a

Karasa Jaga: tdf#134833 icons for Additions

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2020-07-19 07:07:56 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e363f217c1771791b838a001c316d545fa175f77

Icons: tdf#134833 icons for Additions

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Heiko Tietze 2020-07-20 08:50:03 UTC
Guess it's fixed.