Bug 134839 - CRASH: Cutting content of document ( track changes related)
Summary: CRASH: Cutting content of document ( track changes related)
Status: RESOLVED DUPLICATE of bug 133967
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Michael Stahl (allotropia)
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: redlinehide-regressions
  Show dependency treegraph
 
Reported: 2020-07-15 19:29 UTC by Xisco Faulí
Modified: 2020-11-19 11:09 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-07-15 19:29:11 UTC
steps to reproduce:
1. Open attachment 163053 [details] from bug 134827
2. Select all
3. Cut

-> Crash

reproduced in

Version: 7.1.0.0.alpha0+
Build ID: d851a02df57ab378ed0cc6d9362516de09c3279c
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-07-15 19:39:50 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=2dda396f4de051cccf3442f17c84bf2ff5d1db1d

author	Michael Stahl <Michael.Stahl@cib.de>	2019-01-08 13:32:05 +0100
committer	Michael Stahl <Michael.Stahl@cib.de>	2019-01-08 15:16:50 +0100
commit 2dda396f4de051cccf3442f17c84bf2ff5d1db1d (patch)
tree 115172c76198e83cdd1c29e854a84f2794b6a7fe
parent b15f1ed2a1df45a57b587ac90efa90c1c18866fc (diff)
tdf#122452 sw_redlinehide: WW8 import/export sets layout show/hide mode
... and not SetRedlineFlags(), similar to the way the ODF filter does it.

The RTF/DOCX filters don't appear to be able to export the show/hide
flag currently, they can only handle the enabled flag.

Bisected with: bibisect-linux64-6.3

Adding Cc: to Michael Stahl
Comment 2 Telesto 2020-07-15 20:32:47 UTC
The file is an export of the ODT found here: bug 134746 
Note: I recycled the document multiple times for different issues, so you will likely see it more often :-)
Comment 3 Telesto 2020-08-01 18:16:50 UTC
No repro with
Version: 7.1.0.0.alpha0+ (x64)
Build ID: <buildversion>
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: ru-RU (nl_NL); UI: en-US
Calc: CL

Probably same as bug 134770 and duplicate of bug 133967
Comment 4 Xisco Faulí 2020-08-03 09:52:22 UTC
Issue fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=14e87a4b15d31a34e6053f6194688f3aa23af991
Closing as a duplicate of bug 133967

*** This bug has been marked as a duplicate of bug 133967 ***