Bug 134850 - TOC: On removing page number from Table of contents, the hyperlink goes away for second half length of the tab fill
Summary: TOC: On removing page number from Table of contents, the hyperlink goes away ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: TableofContents-Indexes
  Show dependency treegraph
 
Reported: 2020-07-16 07:38 UTC by shariqkeen
Modified: 2021-12-15 19:31 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
gif demo (195.49 KB, image/gif)
2020-07-16 07:40 UTC, shariqkeen
Details
sample doc (16.37 KB, application/vnd.oasis.opendocument.text)
2020-07-16 07:41 UTC, shariqkeen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description shariqkeen 2020-07-16 07:38:31 UTC
Description:
On removing page number from Table of contents [removing #], the hyperlink goes away for second half length of the tab fill. Tab fill is the "...................." which is only clickable for the first half of its length. version 6.4.5 on Linux.

Version: 6.4.5.2
Build ID: a726b36747cf2001e06b58ad5db1aa3a9a1872d6
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: en-IN (en_IN); UI-Language: en-US
Calc: threaded

Steps to Reproduce:
1. Remove page number from Table of contents [removing #] but keep the Tab fill

Actual Results:
The hyperlink goes away for second half length of the tab fill.

Expected Results:
The hyperlink should be present for the entire tab fill.


Reproducible: Always


User Profile Reset: No



Additional Info:
Discussion at https://ask.libreoffice.org/en/question/255251/on-removing-page-number-from-table-of-contents-the-hyperlink-goes-away-for-second-half-length-of-the-tab-fill/
Comment 1 shariqkeen 2020-07-16 07:40:47 UTC
Created attachment 163091 [details]
gif demo

gif showing the preview
Comment 2 shariqkeen 2020-07-16 07:41:38 UTC
Created attachment 163092 [details]
sample doc

sample doc
Comment 3 Dieter 2020-10-28 08:31:23 UTC
I confirm it with

Version: 7.0.2.2 (x64)
Build ID: 8349ace3c3162073abd90d81fd06dcfb6b36b994
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: he-IL (de_DE); UI: en-GB
Calc: threaded

very strange behaviour

Steps to reproduce
1. Open attachment from comment 2
2. Edit index => Add Page number to the first level => O. K.
3. Compare Hyperlink behaviour of tab fill in level 1 and level 2 in TOC
Comment 4 BogdanB 2021-12-15 19:18:24 UTC
Dieter, # field should be inserted between LS and LE fields. If inserted properly no repro in
Version: 7.3.0.0.beta1+ / LibreOffice Community
Build ID: ecfb83d7463bed7c89baeccc03286c1ac9956d70
CPU threads: 4; OS: Linux 5.11; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded

Plase retest.
Comment 5 Dieter 2021-12-15 19:31:01 UTC
Tested with

Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 2934472ab888ebfe64a153984af2902fac63a7a0
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

Hyperlink is now present in every part of tab fill area
=> RESOLVED WORKSFORME