Bug 134877 - No media files played in downloaded Impress presentation with webM in GTK3
Summary: No media files played in downloaded Impress presentation with webM in GTK3
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Media-Playback
  Show dependency treegraph
 
Reported: 2020-07-16 17:06 UTC by r4dh4l
Modified: 2022-04-20 06:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
One slide impress presentation with an embedded WebM video. (4.92 MB, application/vnd.oasis.opendocument.presentation)
2021-06-13 21:18 UTC, r4dh4l
Details

Note You need to log in before you can comment on or make changes to this bug.
Description r4dh4l 2020-07-16 17:06:45 UTC
I use Impress presentations with embedded media files (audio and video) for online lectures very often. I let my audience download the files because I use audio/video conference systems like Mumble without screen sharing. Unfortunately a lot of users reported that slides with embedded media files didn't play the audio or video content. As far as I understood...

- https://ask.libreoffice.org/en/question/200165/audio-fails-to-launch-when-copied-to-another-computer/
- https://ask.libreoffice.org/en/question/854/what-video-formats-does-libreoffice-impress-support/

...LibreOffice impress media files are only played if the operation system supports the embedded file format. I don't think that this is really the case because a presentation with media files created under Debian GNU/Linux is not properly played in a Linux Mint system although the used media files were played on the Linux Mint system.

However: Thank you very much for Libre Office!
Comment 1 Buovjaga 2020-12-14 06:40:57 UTC Comment hidden (obsolete)
Comment 2 QA Administrators 2021-06-13 03:49:18 UTC Comment hidden (obsolete)
Comment 3 r4dh4l 2021-06-13 21:18:51 UTC
Created attachment 172848 [details]
One slide impress presentation with an embedded WebM video.

The attached one slide impress presentation with an embedded WebM video was created under Debian 10.9 and LO 6.1.5.2 ("source system"). After transferring this presentation to a Linux Mint 19.3 system with LO 6.0.7.3 ("target system") the video in the presentation is not visible, just the sound of the video is hearable.

If I play just the embedded video file on the "target system" the video content is visible and hearable so the target system is able to play the video.
Comment 4 QA Administrators 2021-06-14 03:41:43 UTC Comment hidden (obsolete)
Comment 5 Timur 2021-08-20 10:47:09 UTC
No repro Win. 
Repro 6.1 master, no repro 6.2 and 6.3 master and 6.4 oldest (ODS open and webM fine), somewhat repro 6.4 master (ODS opens black but webM runs OK) and 7.3+ (as in 6.4) Linux Mint 19 GTK3. No repro with GEN and SKIA.
Not sure if regression in GTK3 or just some flopping.
I tried bibisect in 6.4 but with no success. I considered black screen already when prez is opened as repro. But still runs video in 6.4 so I guess that spoiled it. 
Someone else may also try.
Comment 6 Timur 2022-04-05 13:31:54 UTC
Upon retest, I don't know why I confirmed this. Let someone else test.
Comment 7 Timur 2022-04-05 13:47:14 UTC
Do you have package gstreamer1.0-gtk3 ? As in bug 124068.
Comment 8 r4dh4l 2022-04-10 17:08:34 UTC
(In reply to Timur from comment #7)
> Do you have package gstreamer1.0-gtk3 ? As in bug 124068.

Meanwhile I've set up my main system with a freh Debian11/bullseye installation so I don't know if it was the case before. Now the situation on my system is

$ apt policy gstreamer1.0-gtk3
gstreamer1.0-gtk3:
  Installed: 1.18.4-2
  Candidate: 1.18.4-2
  Version table:
 *** 1.18.4-2 500
        500 http://deb.debian.org/debian bullseye/main amd64 Packages
        100 /var/lib/dpkg/status

and the media in the attached video of https://bugs.documentfoundation.org/attachment.cgi?id=172848 is played as expected.

Do I have to test again the situation with a random target system like before and does a target system need gstreamer1.0-gtk3 installed to play the embedded media files properly?
Comment 9 Buovjaga 2022-04-10 19:00:48 UTC Comment hidden (obsolete)
Comment 10 r4dh4l 2022-04-10 19:11:00 UTC Comment hidden (obsolete)
Comment 11 Buovjaga 2022-04-10 19:19:00 UTC
(In reply to r4dh4l from comment #10)
> (In reply to Buovjaga from comment #9)
> > No need to test, thanks. I guess we can call this notourbug as it's a
> > packaging dependency issue of your distribution.
> 
> So the problem is caused by LO compiled for Debian and not by
> Windows/Linux/MacOS LO versions opening a presentation with media files?

It is caused by LibreOffice packaged for Debian not installing that gstreamer package as a dependency. Windows and macOS are not using a package manager to install LibreOffice.
Comment 12 Timur 2022-04-11 08:25:21 UTC
This should be reported to Debian or Ubuntu. 
I see in my Mint based on Ubuntu that libreoffice depends on some gstreamer packages but not on gstreamer1.0-gtk3, while it should in GTK3.
Comment 13 r4dh4l 2022-04-19 21:40:35 UTC
(In reply to Timur from comment #12)
> This should be reported to Debian or Ubuntu. 

So I have to report the problem to the Debian and Ubuntu developers?
Comment 14 Buovjaga 2022-04-20 06:13:27 UTC
(In reply to r4dh4l from comment #13)
> (In reply to Timur from comment #12)
> > This should be reported to Debian or Ubuntu. 
> 
> So I have to report the problem to the Debian and Ubuntu developers?

Yes, because this is a packaging issue.