Bug 134910 - LO 7.0 Release Candidate always crashes at startup
Summary: LO 7.0 Release Candidate always crashes at startup
Status: RESOLVED DUPLICATE of bug 135495
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.0.0.1 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-17 18:50 UTC by Rafael Lima
Modified: 2020-08-12 08:19 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael Lima 2020-07-17 18:50:12 UTC
I am having a problem with LO 7.0 RC1 and RC2. I installed them on my Ubuntu 20.04 machine using dpkg as I did with the alpha and beta versions. During the alpha and beta releases, this worked just fine and I could test them.

However, using the same procedure to install the RC versions I get a crash screen at startup and I can only get LO 7.0 running on safe mode. The crash screen says "Unfortunately it seems that LibreOffice crashed when it was last run".

I am not sure if this is a bug or if this is something I did wrong installing it. What I did was download the installer, extract its contents and run:

sudo dpkg -i *.deb

I tried uninstalling and reinstalling. I tried rebooting my computer, but nothing changed. The crashes keep occurring.

I should mention that I have LO 6.4.5 (PPA version) installed and that LO 7.0 did not replace it. Both are still installed, even though I read that installing the RC version would replace my existing installation. LO 6.4 is still working fine.
Comment 1 Adolfo Jayme 2020-07-18 02:13:32 UTC
(PPA packages and TDF packages can co-exist, and that is a feature, not a bug)
Comment 2 Rafael Lima 2020-07-18 16:20:09 UTC
It is good to know that this is a feature. Indeed it is a nice thing to have both versions installed.

However LO 7.0 RC2 keeps crashing at startup whereas LO 6.4.5 doesn't. Is there anything I can do to fix this?
Comment 3 Xisco Faulí 2020-08-11 16:01:17 UTC
This could be a duplicate of bug 135495.

Could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ?
You can install it alongside the standard version.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the master build
Comment 4 Rafael Lima 2020-08-11 17:58:26 UTC
I installed the official 7.0.0.3 version using the PPA and still had the same problem. All LO applications crashed at startup.

I was able to fix it by resetting my user profile. However, I think this should be looked into, because it might be happening with less experienced users that do not know how to reset their user profiles.

I am running LO 7.0.0.3 on Ubuntu 20.04 and Gnome 3.36 (with nvidia graphics card).
Comment 5 Xisco Faulí 2020-08-11 21:52:56 UTC
Hi Rafael,
you should test with a daily build in order to check whether this issue is a duplicate of bug 135495, which I believe so
Comment 6 Rafael Lima 2020-08-12 00:56:30 UTC
(In reply to Xisco Faulí from comment #5)
> Hi Rafael,
> you should test with a daily build in order to check whether this issue is a
> duplicate of bug 135495, which I believe so

I've just done that. I downloaded the following build:

master~2020-08-09_14.07.53_LibreOfficeDev_7.1.0.0.alpha0_Linux_x86-64_deb.tar.gz

I started all LO applications and experienced no crashes this time. I also switched to the tabbed interface and no problems occurred. I guess this issue may have been solved for LO 7.1.

More information about the build I tested:

Version: 7.1.0.0.alpha0+
Build ID: <buildversion>
CPU threads: 16; OS: Linux 5.6; UI render: default; VCL: gtk3
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-08-09_14:07:53
Calc: CL
Comment 7 Xisco Faulí 2020-08-12 08:19:45 UTC
Thanks for testing.
Let's close it as a duplicate of bug 135495

*** This bug has been marked as a duplicate of bug 135495 ***