Bug 134918 - Impress crashes on startup
Summary: Impress crashes on startup
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
7.0.0.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Save
  Show dependency treegraph
 
Reported: 2020-07-17 23:52 UTC by Kai
Modified: 2020-07-18 22:26 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
GDB trace (12.70 KB, text/plain)
2020-07-17 23:52 UTC, Kai
Details
Crash Report (345.29 KB, application/vnd.tcpdump.pcap)
2020-07-18 00:04 UTC, Kai
Details
odp file (22.56 KB, application/vnd.oasis.opendocument.presentation)
2020-07-18 20:08 UTC, Kai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kai 2020-07-17 23:52:08 UTC
Description:
Happens with particular document(s) and even in safe mode. I am attaching the GDB debug log

Steps to Reproduce:
.

Actual Results:
.

Expected Results:
.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
.
Comment 1 Kai 2020-07-17 23:52:39 UTC
Created attachment 163215 [details]
GDB trace
Comment 2 Kai 2020-07-18 00:04:47 UTC
Created attachment 163216 [details]
Crash Report
Comment 3 Roman Kuznetsov 2020-07-18 12:33:25 UTC
can you attach your ODG example file here?
Comment 4 Kai 2020-07-18 20:08:25 UTC
Created attachment 163247 [details]
odp file
Comment 5 Kai 2020-07-18 20:09:09 UTC
Sorry, it's actually an ODP file with a single slide.
Comment 6 Telesto 2020-07-18 20:44:32 UTC
No repro on Windows
Version: 7.1.0.0.alpha0+ (x64)
Build ID: d851a02df57ab378ed0cc6d9362516de09c3279c
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 7 Kai 2020-07-18 21:28:00 UTC
(In reply to Telesto from comment #6)
> No repro on Windows
> Version: 7.1.0.0.alpha0+ (x64)
> Build ID: d851a02df57ab378ed0cc6d9362516de09c3279c
> CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
> Locale: nl-NL (nl_NL); UI: en-US
> Calc: CL

I just downloaded the 7.1 dev build and cannot reproduce it on there either. Do you have 7.0 RC2 or RC1 installed and can check with that one?
Comment 8 Kai 2020-07-18 21:36:38 UTC
I converted it to an ODG with the alpha build and now it opens up fine in 7.0 RC2. However, the formatting got a little messed up...
Comment 9 Kai 2020-07-18 21:48:46 UTC
Another update: Seems like my LO Impress crashes on all files in 7.0RC2, even in safe mode. So it is not a problem with the particular document.
Comment 10 Kai 2020-07-18 21:53:07 UTC
Okay, so fully reseting my install fixes it. I will reopen this bug if I run into the issue again.
Comment 11 Telesto 2020-07-18 22:26:05 UTC
Thanks for the updates. Please reopen if the bug returns.
Setting to worksforme. Fixed is reserved for developers