Bug 134928 - Colibre: Paragraph background color bucket in the sidebar has a red stripe which is confusing
Summary: Colibre: Paragraph background color bucket in the sidebar has a red stripe wh...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Rizal Muttaqin
URL:
Whiteboard: target:7.1.0 target:7.0.2
Keywords:
Depends on:
Blocks: Icon-Theme-Colibre
  Show dependency treegraph
 
Reported: 2020-07-18 12:47 UTC by Telesto
Modified: 2020-09-15 15:14 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screencast (174.50 KB, video/quicktime)
2020-07-21 15:19 UTC, Telesto
Details
Galaxy icon theme use red stripe color (6.32 KB, image/png)
2020-07-21 22:33 UTC, Rizal Muttaqin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-07-18 12:47:46 UTC
Description:
UI: Paragraph background color bucket in the sidebar doesn't change color (similar to highlight or font color)

Steps to Reproduce:
1. Open Writer
2. Properties deck -> Paragraph -> Color below the bucket is always red 

Actual Results:
Always red

Expected Results:
Following the set color (to be consistent)


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: d851a02df57ab378ed0cc6d9362516de09c3279c
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-07-18 12:48:32 UTC
A bug - assume - with the uttermost importance :-)
Comment 2 Heiko Tietze 2020-07-21 13:14:39 UTC
Same question as on bug 132880.

*** This bug has been marked as a duplicate of bug 132880 ***
Comment 3 Telesto 2020-07-21 14:11:18 UTC
@Maxim
Is this really a dupe of bug 132880. Related unrelated from my POV
Comment 4 Maxim Monastirsky 2020-07-21 14:44:37 UTC
I don't see any red color "below the bucket". Maybe you can attach a screenshot of the issue?
Comment 5 Telesto 2020-07-21 15:19:21 UTC
Created attachment 163371 [details]
Screencast

Another way around would be a different theming icon. This outright confusing IMHO
Comment 6 Maxim Monastirsky 2020-07-21 15:43:06 UTC
OK, so this happens with the Colibre icon theme. The red stripe is just part of the icon. This is indeed confusing, as other color buttons use the same area to show the currently selected color. This is a recent change, as the icon in 6.4 didn't have this stripe.
Comment 7 Rizal Muttaqin 2020-07-21 22:31:50 UTC
The color(In reply to Telesto from comment #5)
> Created attachment 163371 [details]
> Screencast
> 
> Another way around would be a different theming icon. This outright
> confusing IMHO

The red stripe color is one of the efforts to give the impression this is an icon for color. The idea is actually related to the icon for character which previously only use an "A" letter, so I give a red color under that "A" letter. Then to make it harmonize, I add that red stripe color to other icons which related to color as well.

For information, this technique is used on the Galaxy icon theme.
Comment 8 Rizal Muttaqin 2020-07-21 22:33:01 UTC
Created attachment 163382 [details]
Galaxy icon theme use red stripe color
Comment 9 Maxim Monastirsky 2020-07-21 22:48:04 UTC
(In reply to Rizal Muttaqin from comment #7)
> The idea is actually related to the icon for character which
> previously only use an "A" letter, so I give a red color under that "A"
> letter.
But the character color toolbar button has the currently used color drawn on top of the red stripe anyway, so in fact that red stripe isn't visible to the end user (except in the customization dialog). So is it really useful to have that stripe as part of the base icon?

> For information, this technique is used on the Galaxy icon theme.
Right, and there were complaints about Galaxy as well, e.g. Bug 82410.
Comment 10 Heiko Tietze 2020-07-22 15:46:45 UTC
How about a rainbow for color*s*? Or a horizontal pencil.
Comment 11 Commit Notification 2020-09-15 06:56:04 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4ece7d97c4866b5e639caff5fb3bcec3dceceb8d

tdf#134928 remove red stripe from background color icons

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2020-09-15 13:48:03 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/bfb8ea0b77fb3e34b9604e4f6e25a0d3ac4169db

Colibre: tdf#134928 remove red stripe from background color icons

It will be available in 7.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.