Bug 134970 - Duplicate Gallery Category/Folder List
Summary: Duplicate Gallery Category/Folder List
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, corruptProfile, regression
Depends on:
Blocks: User-Profile-Upgrade
  Show dependency treegraph
 
Reported: 2020-07-19 23:06 UTC by Rizal Muttaqin
Modified: 2020-07-22 12:18 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
See the screenshot (4.18 KB, image/png)
2020-07-19 23:06 UTC, Rizal Muttaqin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rizal Muttaqin 2020-07-19 23:06:42 UTC
Created attachment 163292 [details]
See the screenshot

Gallery category/folder list has duplicate items, I think this is a regression.

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 0d45380c99c7200075d01860a2315d0ddb450f1c
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: id-ID (id_ID); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-07-20 14:10:28 UTC
Not reproducible in

Version: 7.1.0.0.alpha0+
Build ID: abea0d6647c7f1f7e76c73c26cb80e6a67dc5111
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Rizal, are you using a daily build, a local build or the bisect repository ?
Comment 2 Xisco Faulí 2020-07-20 14:12:10 UTC
Reproduced in

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 1db7decf3fb172542f5fce03ce7bf0cb310d1ffc
CPU threads: 16; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: en-GB (en_GB); UI: en-US
Calc: threaded

(bisect repository)
Comment 3 Xisco Faulí 2020-07-20 14:41:36 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=86b1b062cfc2768a971bb842de1c16f8646d4b4b

author	Heiko Tietze <tietze.heiko@gmail.com>	2020-06-15 16:52:58 +0200
committer	Stephan Bergmann <sbergman@redhat.com>	2020-06-17 12:35:56 +0200
commit 86b1b062cfc2768a971bb842de1c16f8646d4b4b (patch)
tree 546700822f701ce7422ef3f4e331965ac08450ab
parent b982be12281f2eaf63cb9d18a5b3362502c3a1dc (diff)
Resolves tdf#132904 and tdf#133788 - Gallery clean-up

Bisected with: win64-7.1

Adding Cc: to Heiko Tietze
Comment 4 Heiko Tietze 2020-07-21 10:34:29 UTC
Is it working with a clean profile?
Comment 5 Xisco Faulí 2020-07-22 09:56:54 UTC
I do confirm the issue is no longer happening after a 'make clean' and cleaning the profile.

Version: 7.1.0.0.alpha0+ (x64)
Build ID: cd8ad90593232703e36e334c66ece8514ac915ae
CPU threads: 16; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: en-GB (en_GB); UI: en-US
Calc: threaded

@Rizal, could you please doublecheck on your side ?
Comment 6 Rizal Muttaqin 2020-07-22 10:55:05 UTC
(In reply to Xisco Faulí from comment #5)
> I do confirm the issue is no longer happening after a 'make clean' and
> cleaning the profile.
 

Do you mean build myself? I did not build the suite.
Comment 7 Xisco Faulí 2020-07-22 11:00:43 UTC
(In reply to Rizal Muttaqin from comment #6)
> (In reply to Xisco Faulí from comment #5)
> > I do confirm the issue is no longer happening after a 'make clean' and
> > cleaning the profile.
>  
> 
> Do you mean build myself? I did not build the suite.

back to my first question. Where did you get the build from ? Bisect repo? daily build ?
Comment 8 Rizal Muttaqin 2020-07-22 11:24:19 UTC
(In reply to Xisco Faulí from comment #7)

> back to my first question. Where did you get the build from ? Bisect repo?
> daily build ?

Obviously daily build
Comment 9 Xisco Faulí 2020-07-22 11:27:47 UTC
(In reply to Rizal Muttaqin from comment #8)
> (In reply to Xisco Faulí from comment #7)
> 
> > back to my first question. Where did you get the build from ? Bisect repo?
> > daily build ?
> 
> Obviously daily build

have you tried in safe mode ?
Comment 10 Rizal Muttaqin 2020-07-22 11:54:14 UTC
(In reply to Xisco Faulí from comment #9)

> 
> have you tried in safe mode ?

Yes safe mode made the issue gone